Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win


Exchange 2003 recovery problem

Posted on 2011-09-28
Medium Priority
Last Modified: 2012-05-12
Hi Experts,

Windows SBS 2003 running Exchange 2003 as part of it.


Yesterday I received a call from a client stating their email had gone down.  On logging into the server I found that the main data partition on the server was jammed full.  
Talking to the client I decided the best course of action was to move the mailbox database onto another partition so using the exchange system manager I went through the procedure to move the priv1.edb and priv1.stm files to the new location.
Once that was started off I left it going and advised the client it would take some time as the databases were about 30odd GB.

Cut to later that evening, I log into the server to find that its crashed and rebooted its self.  I get logged in and find that the whole data partition on the server has gone!  Ulp, better hope the backups are good...

Incidentally the priv1 files are sitting on the other drive just fine.  The users are able to access their mailboxes in outlook no problem.

So, I recreated the partition and started by recovering the folder structure for the exchange bit of the partition.  Once I do this and reboot exchange comes up and gives me access to the mailboxes that are now on the other drive, however I have no public folders as these files were not backed up at file level.

Stage 2, thinking I'm doing OK, I try to restore the Public Folder Database from the BackupExec backup from the last good backup.  However once I have done this I cannot mount the public folder database and get a 0xfffffde0 message.  At this stage users can no longer access their mailboxes in outlook.

To try and cure this I stopped the store service, moved the database files out to separate location and restarted the store service.  In ESM it showed the public store as offline so I tried to mount it and it gave me the option to create a new database as the files were missing.  All good I though...

Refresh of ESM shows that the mailbox store is now dismounted and will not mount and is giving the same error 0xfffffde0 in the application log.  Having run eseutil /m on the mailbox store I can see its in dirty shutdown state.

What I need to know is, is there anyway I can get this store back online again, or what is the simplest option to get me back up and running ASAP.

Many Thanks for any assistance that you can give me.


Question by:stevencUK
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3

Expert Comment

ID: 36717227

Check the below MS article,


Author Comment

ID: 36717678

I can't see that option on any of the screens in BackupExec.  I'm using version 12 if that helps?

I tried following this article:

This still ends in a fail, however I now find a different error in the app log of 0xfffff749

I have also tryied a different setting in the exchange restore as per:
but I am no further forward.

Why does exchange make it so difficult to get back up and running!

Any further advise appreciated.


Accepted Solution

stevencUK earned 0 total points
ID: 36720058
Have managed to get this up and running eventually.

What we had to do is:

Restore the storage group from BackupExec
Run eseutil /p on each database to get them into clean shutdown state.
Down the ExchangeIS service, delete all files except the 2 .edb and 2 .stm files from the database folder.
Restart the ExchangeIS service and all was then working.

Thanks for the suggestion.

Author Closing Comment

ID: 36902290
Figured out a sequence that worked eventually.

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
how to add IIS SMTP to handle application/Scanner relays into office 365.

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question