Solved

WCF EXCEPTION

Posted on 2011-09-28
5
289 Views
Last Modified: 2012-05-12
When i called WCF service i got this error

The underlying connection was closed: The connection was closed unexpectedly

any help ????
0
Comment
Question by:AhmedHindy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 23

Expert Comment

by:wdosanjos
ID: 36717674
It should be related to a database transaction timing out on the service.  I believe the default timeout value is 60 secs.
0
 
LVL 18

Expert Comment

by:Anil Golamari
ID: 36718273
Try below steps to see whether that may help you with the issue;
1) You'll need to enable tracing (http://msdn2.microsoft.com/en-us/library/ms733025.aspx) at the server side to figure out what caused it to close the connection.

2)  You can see the server traces with the SvcTraceViewer.exe tool (http://msdn2.microsoft.com/en-us/library/ms732023.aspx), which is installed with the SDK (http://www.microsoft.com/downloads/details.aspx?FamilyID=E6E1C3DF-A74F-4207-8586-711EBE331CDC&displaylang=en).
There should be an exception in the server traces which tell what the problem was.
0
 
LVL 8

Expert Comment

by:jagrut_patel
ID: 36812800
It is a very generic error message. Try to debug your WCF service to derive more information. You can even temporarily enable "IncludeExceptionDetailsInFault" service behavior setting to get exact server side exception, if any.

If you are using a stateful service (i.e. PerSession) then you can check whether any service call made before the call on which you get such error has failed or not. Such earlier failed call to an operation could have closed the underlying client side communication channel and thus preventing subsequent calls.
0
 
LVL 4

Accepted Solution

by:
AhmedHindy earned 0 total points
ID: 36813749
i had known the source of the error by enabling debugging and tracing in wcf service


in the web.config of the servicename:
Set compilation debug="true" to insert debugging symbols into the compiled page. Because this affects performance, set this value to true only during development.

<compilation debug="true" strict="false" explicit="true">


0
 
LVL 4

Author Closing Comment

by:AhmedHindy
ID: 36908384
it worked
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes in DotNetNuke module development you want to swap controls within the same module definition.  In doing this DNN (somewhat annoyingly) swaps the Skin and Container definitions to the default admin selections.  To get around this you need t…
While working on Silverlight and WCF application, I faced one issue where fault exception occurred at WCF operation contract is not getting propagated to Silverlight client. So after searching net I came to know that it was behavior by default for s…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question