Solved

Windows 7 RDP to Windows 7 Machine with Netware Client

Posted on 2011-09-28
14
1,845 Views
Last Modified: 2013-11-21
When I RDP to a Windows 7 Pro machine with the Novell Client from an XP machine I am connected to the sign in screen on the remote machine which allows me to select the Novell Client Login option.  However when I RDP from a Windows 7 Pro machine to the remote Windows 7 Pro machine a Windows Security Screen pops up to enter my credentials and I never get the opportunity to select the Novell Client Login.  I then have to log in to Novell After logging in to the workstation.

Is there a way with the Windows 7 Pro MSTSC program to bypass the pop up Windows Credentials screen before being connected to the remote computers log on screen?  i.e. I want to get to the remote's log in screen so that I can pick the Novell Client Login option.
0
Comment
Question by:spaulissian
  • 6
  • 5
14 Comments
 
LVL 24

Expert Comment

by:Lionel MM
ID: 36896222
I don't know enough about Novell to know what the logon screen is but I do know the difference between XP and Windows 7 when you RDP and that may help. In XP you have 3 sections--username, password, and "log onto to". However when you get the logon screen for Win7 its just username and password. As such you can't tell where the client is logging onto--the domain or the local system for authentication. So you can force where to logon to by putting the domainname\then the username (Windows world). You may be able to use that to apply to your situation, namely in the username filed put the logon authentication location and then the username: example
Windows domain name is central and username is lmm
central\lmm in username field.
Hope that helps.
0
 

Author Comment

by:spaulissian
ID: 36897185
I need to get to the windows 7 login screen so I can click on the Novell Login Option
 Windows 7 Login
Then I'm presented with the Log on To Novell Network Screen
 Novell Login
0
 

Author Comment

by:spaulissian
ID: 36897192
When I run MSTSC from a WIndows 7 Pro machine I'm never connected to the Windows 7 Login Screen.  But if I RDP from XP, Linux, or a Thin Client, I do get the Windows 7 Login Screen then I can click the Novell Logon and login to the Novell Network.
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 
LVL 24

Expert Comment

by:Lionel MM
ID: 36898012
Are you starting with this interface?
RDP.bmp
0
 
LVL 24

Expert Comment

by:Lionel MM
ID: 36898031
...when I RDP from a Windows 7 Pro machine to the remote Windows 7 Pro machine a Windows Security Screen pops up to enter my credentials and I never get the opportunity to select the Novell Client Login.

Unlike the XP comments you made, where you said you had the Novel client installed (with the Novell Client from an XP machine), do you also have the Novel client installed on both Win7 systems?
0
 

Author Comment

by:spaulissian
ID: 36903669
Actually the Novell Client is installed on the remote machine I'm trying to remote into not the machine(s) I'm trying to connect from.   Actually to be completely accurate, from local XP machines with or without a Novell Client I have no problems accessing the remote machine with the Novell Client as shown in the picture above.  From a Thin Client with Windows 7 Embedded without a Novell Client I can't access the remote's Novell Client Logon.  From my Windows 7 Pro machine with a Novell Client I'm  unable to access the remote's Novell Client Logon.  I have to log in to the machine and then right click in the system task area for the Novell Icon to get the Novell Login.  Users forget to do the second step and then call me because they don't have any network drives.  It's because they haven't logged into the Novell Network yet. After Logging in must right click the N icon
0
 

Author Comment

by:spaulissian
ID: 36903672
btw, Yes that is the RDP interface I'm using.
0
 
LVL 24

Expert Comment

by:Lionel MM
ID: 36935702
Are you aware that you can use mstsc from a command prompt? If not you can so the solution may be to use that to start the second session from the first. Can you save a RDP file on the systems that don't work as needed; i.e. once you get to past the Windows credential screen can you then connect manually by manually starting a RDP session? IF so, you can add a program startup to the Program Tab mstsc NovellLogon.rdp. In essence what I am suggesting is that you create and save one RDP file with all the required parameters to accomplish connection one and then to have that RDP session start another, the Novell RDP file, one you also created with all the required settings saved on the remote machine.




Windows-RDP.png
0
 
LVL 24

Expert Comment

by:Lionel MM
ID: 36935705
MSTSC      [<Connection File>] [/v:<server[:port]>] [/console] [/f[ullscreen]]  
[/w:<width> /h:<height>] | /Edit"ConnectionFile" | /Migrate | /?

<Connection File> -- specifies the name of an .rdp file for the connection.

/v:<server[:port]> -- specifies the terminal server to which you want  to connect.

/console -- connects to the console session of a server.

/f -- Starts the client in full-screen mode.

/w:<width> -- specifies the width of the Remote Desktop screen.

/h:<height> -- Specifies the height of the Remote Desktop screen.

/edit -- Opens the specified .rdp file for editing.

/migrate -- migrates legacy connection files that were created with Client Connection Manager to new .rdp connection files.

/? -- generates this Usage message.
0
 

Accepted Solution

by:
spaulissian earned 0 total points
ID: 36949956
Here is the solution that I found from Novell Support:

Enabling the TSClientAutoAdminLogon policy

   1.      Click the Start button, then type regedit.exe in the Start Search field.
   2.      Press Enter to open the Registry Editor.
   3.      Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Novell\Login, then add the following:      
      Value Type=REG_SZ, Name=TSClientAutoAdminLogon, Data=1
      Value Type=REG_SZ, Name=DefaultLoginProfile, Data=name of profile to use     Typically, the profile policy name is Default.
   4.      Close the Registry Editor.

0
 

Author Closing Comment

by:spaulissian
ID: 36975409
Solution was provided by Novell support
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question