Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 346
  • Last Modified:

How to manage required fields in SharePoint 2010?

One of our fields in our documents library in SharePoint 2010 has now become REQUIRED, probably due to a mishap on my part. (Now, when we try to edit any document under that library, it says that this field cannot be empty and forces us to enter a value in the said field.)

I can see at several places in SharePoint that the value is now "Required", but I don't see any place where I can CHANGE that back to "Optional".

Can you help me? The simplest way, please, because I'm a beginner.

Thank you.
0
Camoplast
Asked:
Camoplast
  • 5
  • 3
1 Solution
 
svetayeCommented:
Hello,
You can change the field settings under the Library settings in the ribbon.
Enter the default view of the library and find the " Library settings" in the ribbon under the Library tab. Then scroll down to the Collumns group and click on the clolumn name you want to change.
There you can find the "Required" option.
Does it the dropdown field by any chance?
0
 
CamoplastAuthor Commented:
That is the place where we can see that the field is required, but the availability to change it is not there. The Additional Column Settings are not visilble as other fields.
0
 
svetayeCommented:
What is the type of your column?
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
CamoplastAuthor Commented:
Single line of text.
0
 
svetayeCommented:
Is there any chance that we are talking about the "Title" or the " Name" column? What is the default content type of your library?
0
 
CamoplastAuthor Commented:
No it's a new column named "Description" that has been flag as required and should not.
Default content type is Document.
0
 
CamoplastAuthor Commented:
Status: We temporary workaround the issue by editing the content type "Document" to hidden the BAD field. We rename it and create a new field that is now not required.
So at the end we have what we want but we still have the unused renamed bad Column there that we are unable to delete (Gray out or no delete choice).

As information, i validated that no document have metadata using that bad column and that column is not referenced in any view.

If somebody knows a simple trick to delete it, its welcome.
0
 
CamoplastAuthor Commented:
No one has submited any answer outside the workaround we have found.
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now