Why port 25 is not listening in Exchange 2010?

This is a newly setup MS Exchange 2010 server, on windows 2k8 r2 64bit system. After creating send connector, and set few other settings, and rebooting the server. All the exchange services are started, but if I tried to telnet, either locally on the server or remotely from other server in the network, I can't telnet port 25 successfully. Does this mean problem or some settings are not opened?

Thanks in advance...
MezzutOzilAsked:
Who is Participating?
 
Orlando_TechCommented:
Do you have the 2 default receive connections setup?

Hub Transport Server has two initial Receive connectors already in place: The default connector (for handling incoming SMTP email) and the client connector (for handling SMTP relay email). Both of these are configured to be secure by default, and it’s generally a good idea to keep them this way. Anonymous users permission is not enabled by default. Let’s take a closer look at these two connectors now:
Client [ServerName]
This connector is created when installing a Hub Transport server, accepts email from non-MAPI clients for SMTP relay, and is configured to use port 587. It can accept messages from any IP address and has permission to accept mail from Exchange Users, as they are basically authenticated users. The available authentication methods for use with this connector are: Transport Layer Security (TLS), Basic authentication, Exchange Server authentication, and Integrated Windows authentication. Only Exchange users have permission to use this connector.

Default [ServerName]
Also created upon server installation, this connector is configured to accept email from other hub servers and other servers on port 25 (the universal SMTP port). This connector is also configured to accept messages from any IP address, and it is configured with permissions for use by Exchange users, Exchange servers and legacy Exchange servers. The available authentication methods are: TLS, Basic authentication, and Integrated Windows authentication. Exchange users, Exchange users , Exchange Servers and Exchange Legacy Servers have permission to use this connector.

0
 
PradeepCommented:
--> May be the default connector is not configured correctlly.
--> Have you disabled the default receive connector on 2010..?
--> Port25 is SMTP for mail clients to listen and comminucate.
--> The email server you are running needs port 25 to be running so that it can accept mail.  
0
 
MezzutOzilAuthor Commented:
Could it be McAfee antivirus?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
PradeepCommented:
If you suspect it just disable and check once..
0
 
MezzutOzilAuthor Commented:
Hi Orlando_Tech,

Thanks for your detailed information. I checked, both default and client receivers are kept as default. Still, I can telnet port 25 locally on the exchange server, but not on other servers in LAN.
0
 
MezzutOzilAuthor Commented:
Good
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.