?
Solved

Copy/paste doesn't work when I open new document in Ecel

Posted on 2011-09-28
22
Medium Priority
?
263 Views
Last Modified: 2012-05-12
On office 2007, with my Dell N7010, on Windows 7.

Since I got this laptop, I've noticed that if I copy and paste something, THEN open excel, the clipboard doesn't retain the information.

Example: I copy a name from an email. Then I open Excel. I can't paste it, the clipboard is empty. I have to copy the information again.

Example 2: I copy information from a website. Then I open Excel. I can't paste it, the clipboard is empty. I have to copy the information again.

I may have more examples with other programs, but this one for sure happens every time. Thanks.
0
Comment
Question by:mel200
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
  • 9
22 Comments
 
LVL 26

Expert Comment

by:redmondb
ID: 36718754
Hi, mel200,

Is it possible that you have an Auto_Open macro in your Personal.xls? which clears the clipboard?

Regards,
Brian.
0
 

Author Comment

by:mel200
ID: 36718767
Thanks for your fast help! how could I check that?
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36718974
Mel,

I'm assuming you're not comfortable editing (or at least looking at) at macros, so let's start with a quick check as to whether or not you have a Personal.xlsm ( or .xlsb or .xls).

In Excel, hit Alt-W to display the View Ribbon. If the Unhide button is enabled, click on it. At least one spreadsheet will be listed - let me know the name(s).

Thanks,
Brian.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 26

Expert Comment

by:redmondb
ID: 36719025
Mel,

I'm on Excel 2010, so my instructions above should be OK for 2007, but just in case, I've attached a screenshot.

Regards,
Brian.  
Unhide
0
 

Author Comment

by:mel200
ID: 36719111
Ok, I see Book1. I've clicked  on it and it's open.
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36719177
Mel,

OK. Click on Cancel and then Alt-F8, please. This will display a list of any macros (please see attached).

Thanks,
Brian
 Macro
0
 

Author Comment

by:mel200
ID: 36719245
OK- no macros.
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36719313
Mel,

OK, click Cancel, please.

Next possibility is an add-in. Alt-F11 brings up the Visual Basic Editor. Please let me know if there are any names on the left hand side (please see attached).

Thanks,
Brian.
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36719327
Oops. VBE
0
 

Author Comment

by:mel200
ID: 36719549
screenshot of names
I've attached an image screenshot of names.
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36719814
Mel,

Thanks. I'm afraid that disproves my theory.

Let me do some googling.

Regards,
Brian.
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36719859
Mel,

Oh, another thought first. It's notoriously easy to clear the clipboard in Excel (e.g. simply updating a cell). Could you give me your exact sequence of actions from copying in Outlook to realizing that the clipboard is empty.

Also, how long has this problem been happening?

Thanks,
Brian.
0
 

Author Comment

by:mel200
ID: 36719955
It's been happening since I got the laptop, last January. Sequence of actions:

-With Excel closed, I copy text from an email. (highlight and CTRL-C, or right-click and COPY)
- I open Excel.
-I click in a cell and click CTRL-V. Or I right-click to paste, but paste is greyed out.
- I can't paste it, the clipboard is empty. I have to copy the information again.(I've tried viewing the clipboard, and it is empty at this point.)

This happens every time.
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36720044
Mel,

Thanks. I'm going to try the same sequence - how do you start Excel?

Regards,
Brian.
0
 

Author Comment

by:mel200
ID: 36720640
Just from my start menu, I have it pinned there. Thanks.
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36725978
Mel,

Sorry for the delay - I was digging out Excel 2007.

It works fine for me.

There's one last thing I can think of to try (see attached)...
Click on the Orb. Click on "Excel Options". Click on "Add-Ins". Screen capture the details and post it.

Thanks,
Brian.

 Options_1 Options_2
0
 

Author Comment

by:mel200
ID: 36732192
Sure here it is. :)

 capture
0
 
LVL 26

Accepted Solution

by:
redmondb earned 2000 total points
ID: 36748852
Mel,

Thanks, that's encouraging. Any of those COM Add-Ins could be the source of the problem.

I know you mentioned that the problem occurred whether you used either Outlook or your browser but I'd like to keep this as simple as possible, so could you check that it also happens when you copy from NotePad? If it does, then use that for the following. If it doesn't then let me know before doing anything else (as it's possible that the problem isn't Excel).

OK, assuming the problem happens with NotePad...

So far, we've haven't updated anything but that's going to change now - teeth brushed, seatbelt on and backups up to date?!

At the bottom of the Options' Add-Ins tab click on the drop-down and change it from "Excel Add-Ins" to "COM Add-Ins" and click on "Go" (please see attached).

Another dialogue is displayed listing the COM Add-Ins with a check box beside each one. Untick one of the ticked Add-Ins and click on "OK" (start with the Google one). Shut down Excel and re-test. If that doesn't fix it, repeat the process until the problem goes away or all of the Add-Ins are unselected.

Fingers crossed,
Brian.
Options_3
0
 

Author Comment

by:mel200
ID: 36761706
OK, thanks, Brian. It does happen with notepad. I don't feel quite ready to do that tonight, so will attack it tomorrow morning when my mind is fresher. Thanks for all your help!
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36762945
Mel,

Thanks for keeping me posted.

All the best tomorrow,
Brian.
0
 

Author Closing Comment

by:mel200
ID: 36818969
Adobe Contribute Plugin!! You're a genius!
0
 
LVL 26

Expert Comment

by:redmondb
ID: 36890989
Mel,

Excellent!

Thanks and all the best,
Brian.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
This article describes how to use a set of graphical playing cards to create a Draw Poker game in Excel or VB6.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question