Solved

Cisco phone wrong vlan

Posted on 2011-09-28
31
621 Views
Last Modified: 2012-05-12
So I am not to sure why this is happening but whenever I plug this phone into the data jack it keeps showing up in the access vlan. So data jack to phone, phone hooks to pc. Configuration is straight forward and yes cdp is enabled. I can see the device when doing a show cdp nei.

switchport mode access
switchport access vlan 51
switchport voice vlan 50
spanning-tree portfast

I have the SVI's created on a 6509. I just don't understand why the phone keeps showing up in vlan 51, hence it never receives its configuration.
0
Comment
Question by:chipsch
  • 17
  • 11
  • 2
  • +1
31 Comments
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Are the cables to the phone connected correctly? Not reversed?
0
 

Author Comment

by:chipsch
Comment Utility
Main cable goes to the 10/100 SW port and the pc into the 10/100 PC port.
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Is the plugged directly into the 6509 or another switch? If another switch, is the voice vlan getting trunked to the access switch where the phone is plugged into?
0
 

Author Comment

by:chipsch
Comment Utility
we have a vtp domain set up with pruning. The access switch shows it as trunking the data vlan and voice vlan not to mention other vlans that are set up. The core switch on the other hand is pruning the voice vlan due to lack of request by neighbor.
0
 

Author Comment

by:chipsch
Comment Utility
If I put the port in access vlan 50 for the voice it will pull the dhcp information then traverse the l2l tunnel to pull the configuration files and start working also.
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Hmmm, if the core switch is pruning it, then it isn't getting to the core switch correct? Did the vlan get created on the access switch by vtp?n Is the core the vtp server?
0
 

Author Comment

by:chipsch
Comment Utility
core is the vtp server and yes when doing a show vlan br it shows up on both devices.
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
post a show int trunk from both switches
0
 

Author Comment

by:chipsch
Comment Utility
Port          Mode         Encapsulation  Status        Native vlan
Gi4/36        on           802.1q         trunking      1

Port          Vlans allowed on trunk
Gi4/36        1-4094

Port          Vlans allowed and active in management domain
Gi4/36        1-3,5,9-10,12-13,15-16,18-19,21-22,32,48,50-52,66,90,100,104-113,118-119,152,160-161,165,170,199,216,220,223,230,251-253,260,270,289-290,300,332-341,347-349,401,501-502,504,512,516,600-601,800,999-1000

Port          Vlans in spanning tree forwarding state and not pruned
Gi4/36        1,51,253

that was the core and below is the access, had to use show int switchport for that one and a pruning because it doesn't support the show int trunk command.

Name: Gi0/2
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-3,5,9,10,12,13,15,16,18,19,21,22,32,48,50-52,66,90,
     100,104-113,118,119,152,160,161,165,170,199,216,220,223,230,251-253,260,
     270,289,290,300,332-341,347-349,401,501,502,504,512,516,600,601,800,999,
     1000
Pruning VLANs Enabled: 2-1001

Port    Vlans pruned for lack of request by neighbor
Gi0/2   NONE

Port    Vlans traffic requested of neighbor
Gi0/2   1,51,253


Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Self Loopback: No


0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
What kind of switch is the access switch? The problem is that your vlan 50 is being pruned for some reason.
0
 

Author Comment

by:chipsch
Comment Utility
If I set the switchport to trunking the phone will come up but the data side does not. It sets the pc to the native vlan of 1 but I need it on vlan 51 preferably without setting the native vlan to 51.
0
 

Author Comment

by:chipsch
Comment Utility
3548XL
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Post the 6509 trunk config connecting to the access switch, and trunk config on the access switch.
0
 

Author Comment

by:chipsch
Comment Utility
core:

interface GigabitEthernet4/36
 description Trunk for AS24
 switchport
 switchport mode trunk
 no ip address
end

access:

interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

0
 
LVL 18

Expert Comment

by:fgasimzade
Comment Utility
Make sure admin vlan is NOT set to 51 in network settings of the Phone.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:chipsch
Comment Utility
It isn't, it is set to 50 on operational and admin with the pc vlan set to 51
0
 
LVL 18

Expert Comment

by:fgasimzade
Comment Utility
Admin vlan needs to be 50 or blank to receive it from the switch
0
 

Author Comment

by:chipsch
Comment Utility
Admin vlan is set to 50 at this time as well as operational and the pc vlan is set to 51
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Can you post sh spanning tree vlan 50 for both switches?
0
 

Author Comment

by:chipsch
Comment Utility
If I set the interface on the access switch to trunk and dot1q encapsulation the phone gets put in vlan 50 but the pc in vlan 1, the native. I would think that if the phone is programmed with pc vlan 51 it would put it there.
0
 

Author Comment

by:chipsch
Comment Utility
Interesting set it to trunk and made the native vlan 51 and this is what I get.


0001.6c9e.f223       Dynamic          1  FastEthernet0/12
0001.6c9e.f223       Dynamic         51  FastEthernet0/12
8cb6.4ff6.f925       Dynamic          1  FastEthernet0/12
8cb6.4ff6.f925       Dynamic         50  FastEthernet0/12
8cb6.4ff6.f925       Dynamic         51  FastEthernet0/12
0
 

Author Comment

by:chipsch
Comment Utility
access switch spanning tree:


Spanning tree 50 is not currently active
The following parameters have been configured :

Stp Status         : Disabled
Protocol           : IEEE
Max Age (sec)      : 20
Hello time (sec)   : 2
Forward Delay (sec): 15
Bridge Priority    : 32768

core switch:

VLAN0050
  Spanning tree enabled protocol rstp
  Root ID    Priority    20480
             Address     00d0.0584.3c32
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    20480
             Address     00d0.0584.3c32
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi4/8            Desg FWD 4         128.392  P2p
Gi4/11           Desg FWD 4         128.395  P2p
Gi4/13           Desg FWD 4         128.397  P2p
Gi4/14           Desg FWD 4         128.398  P2p
Gi4/27           Desg FWD 4         128.411  P2p
Gi4/28           Desg FWD 4         128.412  P2p
Gi4/29           Desg FWD 4         128.413  P2p
Gi4/31           Desg FWD 4         128.415  P2p
Gi4/32           Desg FWD 4         128.416  P2p
Gi4/33           Desg FWD 4         128.417  P2p
Gi4/34           Desg FWD 4         128.418  P2p

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------

Gi4/35           Desg FWD 4         128.419  P2p
Gi4/36           Desg FWD 4         128.420  P2p
Gi4/37           Desg FWD 4         128.421  P2p
Gi4/38           Desg FWD 4         128.422  P2p
Gi4/39           Desg FWD 4         128.423  P2p
Gi4/40           Desg FWD 4         128.424  P2p
Gi4/42           Desg FWD 4         128.426  P2p
Gi4/44           Desg FWD 4         128.428  P2p
Gi4/45           Desg FWD 19        128.429  P2p
Gi4/47           Desg FWD 4         128.431  P2p
Fa7/20           Desg FWD 19        128.788  P2p
Fa7/21           Desg FWD 100       128.789  P2p
Fa7/27           Desg FWD 19        128.795  P2p
Fa7/28           Desg FWD 19        128.796  P2p
Fa8/27           Desg FWD 19        128.923  P2p
Fa8/28           Desg FWD 19        128.924  P2p
Po2              Desg FWD 3         128.1666 P2p
Po5              Desg FWD 3         128.1669 P2p
Po19             Desg FWD 3         128.1670 P2p

0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
On the 6500 trunk can you try:

switchport trunk pruning vlan remove 50. Also can you ensure the access switch is running the same vtp version as the 6500.
0
 

Author Comment

by:chipsch
Comment Utility
Same version password domain whole nine yards, that is where the access switch got vlan 50 added into its database. Even though it is pruning why would on the local switchport it come up in the wrong vlan......


0001.6c9e.f223       Dynamic         51  FastEthernet0/12
8cb6.4ff6.f925       Dynamic         51  FastEthernet0/12

The second mac-address is the phone.
0
 
LVL 26

Accepted Solution

by:
Soulja earned 500 total points
Comment Utility
Is the phone set up to tag 802.1q?
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
Try testing the trunk using the PC...

Configure the port for VLAN 50 (removing the voice vlan config) and see if the PC gets an IP address - if it does your trunk to the core is ok.
0
 

Author Comment

by:chipsch
Comment Utility
switchport trunk encapsulation dot1q
 switchport trunk native vlan 51
 switchport trunk allowed vlan 1,50,51,1002-1005
 switchport mode trunk
 switchport voice vlan 50

That seemed to fix it. Jeez what a mess, these old things HAVE got to go. Thank you so much for everyones help.
0
 

Author Closing Comment

by:chipsch
Comment Utility
Thanks for all of the help. Although I figured it out in the end Soulja it was like I was IM'ing you to get this working. Thanks for the awesome support.
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
No way you should have add to have that type of config. Very strange indeed. The whole point of voicevlan is so you don't have to change the port into a trunk configuration.
0
 

Author Comment

by:chipsch
Comment Utility
Well it looks like the 3548XL supports the command but decides to regurgitate it into your face after 4 hours of trying to hook up a simple ip phone.
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Yeah, that is a old switch after all. I am very sure this would not have been an issue on the newer switches.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

The Zaptel people (www.zaptel.com) got kind of annoyed with the fact that they were getting bombarded with searches for the zaptel driver system for Asterisk (not to mention they own the trademark on zaptel). So, they kindly requested that Digium ch…
Every year the snow affects people and businesses. According to the Federation of Small Businesses (FSB), in 2009, UK businesses lost an estimated £1.2bn (http://news.bbc.co.uk/1/hi/business/7864804.stm) because of bad weather. This article was c…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now