installing error

when installing, getting the below
tools.bmp
LVL 5
25112Asked:
Who is Participating?
 
Daniel_PLConnect With a Mentor DB Expert/ArchitectCommented:
Run main setup, directly from root od DVD/CD drive., choose install Server components, tools, Books online...
At the screen Components to Install click on Advanced button. Next choose BIDS from client components node. Components to Install screen Feature selection - Advanced
0
 
25112Author Commented:
this is for BIDS 2005 (tools) machine does not have DB engine for 2005..

but complete install is in there for 2008..

is there a problem if 2008 was installed first?
0
 
25112Author Commented:
we prefer not to install anything 2005 other than the BIDS, if at all possible..
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
25112Author Commented:
If you have SQL 2008 complete install and no SQL 2005 of any sort, would you be willing to install the SqlRun_Tools.msi file in 2005 CD to only install BIDS?
0
 
25112Author Commented:
thanks daniel.
just running the SqlRun_Tools.msi  won't do it?
0
 
Daniel_PLDB Expert/ArchitectCommented:
It may help because it installs support files first.
0
 
25112Author Commented:
>>It may help because it installs support files first.

are you saying CD install from menu maybe is better than just running SqlRun_Tools.msi?

also, did you run the above on a machine that already had SQL 2005?
0
 
Daniel_PLDB Expert/ArchitectCommented:
>are you saying CD install from menu maybe is better than just running SqlRun_Tools.msi?
Yes, it installs Support Files which probably is the case here because you have already installed 2008 product.

>also, did you run the above on a machine that already had SQL 2005?
Yes
0
 
25112Author Commented:
I am quiet following the 'support files'.. what are they.. are these the help files? (F1)

are they mandatory or optional?

SQL 2008 would have already the support files. are they the same as SQL 2005 support files or different?

why i am asking is the SqlRun_Tools.msi file gave error.. but you did not get the error.. is it because you already had sql 2005 installed?
0
 
Daniel_PLDB Expert/ArchitectCommented:
Support files for installation process. Just try the installation.
0
 
Jason Yousef, MSConnect With a Mentor Sr. BI  DeveloperCommented:
1.       Run the Client tools setup from SQLrun_tools.msi and when the feature selection screen comes, select one Client component at a time and EXCLUDE Management Tools to be installed at the end.

2.       Follow any sequence ( like first select Only BIDS under Client Tools Selection Screen.. Install it .... after that run the Setup again->SQLRun_tools.msi and this time select Legacy components.. and so on... )

3.       After all the other Client Components were installed, INSTALL THE MANAGEMENT TOOLS by running the SQLRun_tools.msi setup.

Client tools setup should succeed now.

4.       Although exact reason is unknown at this time, I guess this could be a timing issue as the required DLL's or resource files are not there for the management tools to complete.
0
 
Daniel_PLDB Expert/ArchitectCommented:
@huslayer
Asker wants to install BIDS only. Widely distributed resolution about installing one component at a time doesn't apply here because there is already one component installed at a time - it is BIDS 2005.

>ID:36719527 Author:25112 Date:28/09/11 09:32 PM
>we prefer not to install anything 2005 other than the BIDS, if at all possible..
0
 
25112Author Commented:
>>Run the Client tools setup from SQLrun_tools.msi

@huslayer, apparently the support files of 2008 did not help? it needs 2005 support files, and hence SQLrun_tools.msi is failing?

can you try to run SQLrun_tools.msi on a machine that has never had SQL 2005 CD before?
0
 
Jason Yousef, MSSr. BI  DeveloperCommented:
the support files and client tools are different from 2008 to 2005.

>>can you try to run SQLrun_tools.msi on a machine that has never had SQL 2005 CD before?

do you mean the machine had never installed 2005 but has 2008 installed, or it doesn't have anything at all installed?
0
 
25112Author Commented:
>>do you mean the machine had never installed 2005 but has 2008 installed, or it doesn't have anything at all installed?
both.
i tried
a)machien with SQL 2008 - complete installation and not SQL 2005 at all - I then ran the 2005 SQLrun_tools.msi, but the above error message was got (picture in question)
b)tried in machine that had no SQL at all before.. I ran 2005 SQLrun_tools.msi  and i got the below
install-error.bmp
0
 
25112Author Commented:
in both the above cases, i assume 2005 support files would not be per-existing in the machine
0
 
Jason Yousef, MSSr. BI  DeveloperCommented:
I've a VM with 2005 and 2008, but 2005 was installed prior to 2008, am not sure if you can do the opposite, never had to do that scenario.
0
 
25112Author Commented:
>>I've a VM with 2005 and 2008, but 2005 was installed prior to 2008, am not sure if you can do the opposite, never had to do that scenario.

are you saying that because you already had the regular install already, so if you do BIDS only now from the msi file, you will be OK and no error?
but i did not have the setup files before, and  hence getting the error frmo msi install file?
0
 
Jason Yousef, MSSr. BI  DeveloperCommented:
so what do you have installed now? and what you're trying to install?
I am confused now :(

the best way to do what you're trying to do is to download a free virtualization software, such as VMware player or VirtualBOX and have 2 separate environments for testing and for conflict free.
0
 
25112Author Commented:
@huslayer, i am good now, because i went through the CD menu.. but I was just trying to understand why SQLrun_tools.msi gave me error on both counts
0
 
Jason Yousef, MSSr. BI  DeveloperCommented:
But still, listen to my advise if you need more than version of SQL or VS, because you'll use once or twice, maybe for testing, so it doesn't worth the hassle of fighting errors and conflicts.

clean smooth installation is the best.
0
 
25112Author Commented:
>listen to my advise
yes. thanks.

>>if you need more than version of SQL or VS
i don't get you.. are you asking if it won't be used much

>clean smooth installation is the best.
yes that is what i wanted to understand.. and my understanding right now from you and Daniel is that I have to install from CD, if first time, and then choose BIDS 2005 only. If VS 2005 is already installed, then I don't have to install BIDS 2005. But if Can installed 2005 SQL DB Engine, if I needed to, right?
0
 
Daniel_PLDB Expert/ArchitectCommented:
>@huslayer, i am good now, because i went through the CD menu.. but I was just trying to understand why >SQLrun_tools.msi gave me error on both counts
As I wrote, your problem was in not having Support Files installed.

>yes that is what i wanted to understand.. and my understanding right now from you and Daniel is that I have to >install from CD, if first time, and then choose BIDS 2005 only. If VS 2005 is already installed, then I don't have to >install BIDS 2005. But if Can installed 2005 SQL DB Engine, if I needed to, right?
Yes, indeed you can install additional components later, including the database engine itself ;)
0
 
25112Author Commented:
thanks for confirming
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.