Solved

editing with ADSIedit, all fields i want to change are greyed out

Posted on 2011-09-28
13
1,990 Views
Last Modified: 2012-05-12
Logging in as domain admin,
connect to the adsi, I can see the area I want to change but it is greyed out.
I have run ADSIedit as administrator, logged in with domain\administrator account, but not all of the attributes are editable,  state  <not set>

trying to follow an article for send and receive issues on a exch 2010 server...        msExchSmtpReceiveMaxMessageSize

any help would be nice, not a very big user of ADSIedit....
0
Comment
Question by:cvvood
  • 5
  • 5
  • 3
13 Comments
 
LVL 6

Expert Comment

by:Em Man
ID: 36765672
hmmm... I was able to edit it, but because I am a member of Enterprise Domain Admins.
0
 
LVL 6

Expert Comment

by:Em Man
ID: 36767499
Also I am an Exchange Full Administrator. (under Exchange Admin Delegation)
0
 
LVL 39

Expert Comment

by:Krzysztof Pytko
ID: 36812969
Check with Enterprise Administrator or Schema Administrator account. By default only them are allowed to modify anything in Schema.

Regards,
Krzysztof
0
 
LVL 5

Author Comment

by:cvvood
ID: 36816785
OK, the Admin is a member of:   administrators, domain admins, domain users, enterprise admins group policy creator owners, organization management, schema admins.

I am accessing the server through RDP if that makes any difference.

everything is still greyed out..
0
 
LVL 39

Expert Comment

by:Krzysztof Pytko
ID: 36890719
Check that attribute's security tab and check if other administrator didn't change permissions to modify that object.
Can you tell me please what you exactly want t ochange and where?
Thanks in advance

Krzysztof
0
 
LVL 5

Author Comment

by:cvvood
ID: 36943481
krzysztof,

I have exchange 2010, where some of the defaults are listed in the Directory like:
msExchESEParamCacheSizeMax
msExchMaxAttachmentSize

but still no luck, I cannot edit, I am logged in as Domain Admin,  with Schema admin and the likes.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 39

Expert Comment

by:Krzysztof Pytko
ID: 36943746
OK, but where in ADSI Edit, you try to do that?
If in Configuration -> Services -> Microsoft Exchange -> <OrganizationName> -> Administrative Groups -> <AdministrativeGroup> -> Servers -> <ServerName> -> InformationStore then by default these attributes cannot be modified by Domain Admins or Schema Admins. You need to be a member of Enterprise Admins or Organization Management (I checked that in my test environment)

Can you verify once again if you are member of one of these groups, please?

Krzysztof
0
 
LVL 5

Author Comment

by:cvvood
ID: 36943959
yes, did look into that. I am attaching a copy of the "member of" for the Administrator
adsi-memberof.jpg
0
 
LVL 6

Expert Comment

by:Em Man
ID: 36946631
Are you using the version of ADSIEdit that comes with Windows 2008 Server? If not, you can install it by opening a command prompt and entering ServerManagerCmd -i RSAT-ADDC
0
 
LVL 5

Author Comment

by:cvvood
ID: 36948591
PS C:\Users\administrator.*******> ServerManagerCmd -i RSAT-ADDC

Servermanagercmd.exe is deprecated, and is not guaranteed to be supported in future releases of
at you use the Windows PowerShell cmdlets that are available for Server Manager.


ArgumentNotValid: Invalid role, role service, or feature: 'RSAT-ADDC'. The name was not found.
0
 
LVL 39

Expert Comment

by:Krzysztof Pytko
ID: 36948633
OK, try to do that this way. Download and install RSAT on your clients (if Win7) or install Support Tools from Server 2003 CD1 (if XP) and run on your machine adsiedit.msc and check again.

On a server, you may do one more step. Go to

c:\Users\<UsedProfile>\AppData\Roaming\Microsoft\MMC
and delete adsiedit file. Re-run console and check again. Maybe something wrong with console? Permissions are correct, for sure

Krzysztof
0
 
LVL 5

Author Comment

by:cvvood
ID: 36948739
This is a 2008 r2 environment,  should I do it from the cd's for 2008 r2?  and the command line didn't work for installing the adsiedit from the command line. I went to Features and installed the rsat tools.
0
 
LVL 39

Accepted Solution

by:
Krzysztof Pytko earned 500 total points
ID: 36949292
If you have 2008 R2 DC then adsiedit.msc is available by default and there you should go to delete that configuration file.
For 2008 R2 member server you need to add RSAT tools and from Control Panel chose what to install. See this (it's for 7 but the same steps are for 2008)
http://www.petri.co.il/remote-server-administration-tools-for-windows-7.htm

Krzysztof
0

Featured Post

Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a tradeshow? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

Join & Write a Comment

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now