Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Change Exchange 2003 free/ busy setting

Posted on 2011-09-28
17
Medium Priority
?
942 Views
Last Modified: 2012-05-12
Hi there,

We have Exchange 2003 SP2 Standard server and Outlook 2003 professional installed on users computer.  By default, the Outlook calendar only allows to view free/ busy information for 2 months.  

1. How can I get the Outlook to display free/ busy information for 4 months as suppose to 2 months (changing the free/ busy months on Outlook doesn't make any difference)? Is there anything has to be done on the Exchange server?

2. Is there any impact on Exchange server performance when changing free/ busy from 2 months to 4 months?

Thanks and appreciate all your help in advance!
0
Comment
Question by:BeerTime
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 4
17 Comments
 
LVL 6

Expert Comment

by:Em Man
ID: 36803700
Here's some answers.

http://blogs.technet.com/b/exchange/archive/2004/06/10/152698.aspx

depends how many clients are accessing the servers and server specs.
0
 
LVL 9

Accepted Solution

by:
MNH1966 earned 1336 total points
ID: 36813796
Here's a nice way to do it using a GPO: http://blogs.technet.com/b/exchange/archive/2004/06/10/152698.aspx

Impact on exchange is that the Free/Busy public folder will grow slightly (in percentage: a lot, in reality: not much :))
0
 

Author Comment

by:BeerTime
ID: 36813950
Thanks for your inputs! Do you know why I am not able to see free/ busy for more than 2 months if I change the months in Outlook setting manually? I just want to make sure it works before applying GPO.  

Thanks!
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 9

Expert Comment

by:MNH1966
ID: 36814073
It depends. If you have CDO applications, such as Blackberry Enterprise Server, they may override the free/busy with the default setting. Try starting Outlook with the /CleanFreeBusy option.
Look at how far ahead the free busy is published and wait a while. If it's then reset, you probably have some other application overriding the Outlook published data.
0
 

Author Comment

by:BeerTime
ID: 36814559
We have a BES server with only 4 users.  I don't have a BlackBerry and my mailbox is not on the BES, I've tried changing the Outlook free/busy to 4 month and started Outlook with /cleanfreebusy but no luck.  The Outlook Calendar shows \\\\\\ (empty back slashes) starting Nov 01 -- which means it is still showing 2 months.

Any ideas?
0
 
LVL 9

Expert Comment

by:MNH1966
ID: 36814614
Any other processes running on your machine that might be interacting with Outlook?
I had similar problems in the past, but cleanfreebusy usually fixed them at least temporarily.
Maybe try running it from another machine with a fresh profile?!?
0
 

Author Comment

by:BeerTime
ID: 36814685
I've tried it on a new machine, new profile and having the same problem.  Is there any settings on the Exchange that need to be changed? again, we are using Exchange 2003 standard.

Thanks!
0
 
LVL 6

Expert Comment

by:Em Man
ID: 36815112
"By default, Outlook publishes the free/busy data for a user once every 15 minutes and again when Outlook is being shut down. Every message includes the entire free/busy information for the corresponding user that ranges from the current month to two months in the future. If you want to change this behaviour you can do this in Outlook general properties. The only thing you cannot change is the setting where you can't publish any information apart from the current month, because it is hard coded."
0
 
LVL 6

Assisted Solution

by:Em Man
Em Man earned 664 total points
ID: 36815132
To resolve this issue, you must include the period for which you want to publish Free/Busy information in a registry entry. Configure this registry entry on the Microsoft Exchange Server on which you have installed the Auto Accept Agent. Configure the entry under the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Excdo\Parameters
Name: FBPublishMonth
Value type: DWORD
Value data: The period, in months, for which you want to publish Free/Busy information
For example, if you want to publish Free/Busy data for 4 months, type 4 in the Value data box.

NOTE for Microsoft Exchange Server 2010, the DWORD is FBPublishMonths

After you add this key, you must restart the Internet Information Services (IIS) Admin Service and the System Attendant service for this change to become effective.
0
 
LVL 6

Expert Comment

by:Em Man
ID: 36815146
and here's the more detailed part. :)

http://blogs.technet.com/b/exchange/archive/2004/06/10/152698.aspx


Hope this fix your problem.
0
 

Author Comment

by:BeerTime
ID: 36815747
Thanks again, I am not able to find "Excdo" under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft on the Exchange server 2003.  I search for "FBPublishMonth" under HKEY_LOCAL_MACHINE and was not found.  any idea??
0
 
LVL 6

Expert Comment

by:Em Man
ID: 36818441
You need to add these keys.
0
 

Author Comment

by:BeerTime
ID: 36820197
Thanks, I don't feel too comfortable creating registry keys on the Exchange server. Is there any other option to change free/ busy month in system manager? or anywhere else on the Exchange server?

Thanks again.
0
 
LVL 9

Assisted Solution

by:MNH1966
MNH1966 earned 1336 total points
ID: 36890096
I'm afraid not, but perhaps this official MS knowledge base article gives you the confidence you need :) http://support.microsoft.com/kb/917687
0
 

Author Comment

by:BeerTime
ID: 36890867
Thanks a lot, I will review the article and let you know if I have any questions.
0
 

Author Comment

by:BeerTime
ID: 36919195
Thanks everyone for your help on this!
0
 

Author Closing Comment

by:BeerTime
ID: 36919208
Thanks everyone for your help on this!
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question