Right to reboot Hyper-V guest machine

I have create a hyper-V guest machine and already grant local administrator right and domain server operators to a user. However, the user couldn't reboot the server unless I give him the Domain admins right. Have any idea for this ?

Thanks
AXISHKAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Lester_ClaytonConnect With a Mentor Commented:
Aha!

Yes, this can be sometimes an annoying feature - when the only two options is logoff and disconnect.  I have this problem sometimes.  It drives me crazy - this usually happens on a Workstation OS rather than a server OS.

To overcome it, I shut down using the command prompt.

To shut down:
shutdown -s -t 0

Open in new window


To reboot:
shutdown -r -t 0

Open in new window


To do a forced reboot
shutdown -f -t 0

Open in new window


the -t 0 specifies 0 seconds - i.e. immediately
0
 
Lester_ClaytonCommented:
Was he trying to reboot the server through Hyper-V Manager?  Being a local administrator of a virtual machine won't give him rights to use Hyper-V - which is why Domain Admin was required in that case.

The thing is, Domain Admin grants far too much rights.  Instead, give him Local Admin on the server(s) which run Hyper-V - that way he will be able to use Hyper-V manager, and be able to reboot machines.

With SCVMM (System Center Virtual Machine Manager) you can grant much more granular rights.
0
 
AXISHKAuthor Commented:
Sorry for the confusion. Actually, the user connects to the guest machine through Remote Desktop but it doesn't allow to reboot the server. The user doesn't need to reboot the guest OS through the Hyper-V host.

The user has been added to the local administrator of the server (guest machine) but there is no reboot option provided. Any idea ?

Thanks


0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
penguinjasConnect With a Mentor Commented:
If you go to start you can select windows security and you should get an option to restart the server.  If it's a 2008 server you can select the red icon lower left to shutdown or restart.  If it's 2003 you get the shutdown button and can choose options from a drop down menu.  
0
 
AXISHKAuthor Commented:
Issue the control and it just tell "Access is denied".

Again, the user has been granted with local administrator of the server, and server operators of the domain. Any idea ?

Thanks
0
 
AXISHKAuthor Commented:
One more add, the server is a guest OS on a Hyper-V server. I haven't grant the local administrator right for the server. I only grant local administrators for the user on guest OS.

Will that be the problem ?

Thanks
0
 
penguinjasCommented:
So user is a local administrator on the guest OS machine you are trying to reboot.  When you added the user did you logon to the guest OS as an administrator to add the user into the group or do it remotely?  If you did it remotely like through computer management the user needs to logoff of the guest and log back on before the permissions will take effect.
0
 
AXISHKAuthor Commented:
The problem was caused by one of the GPO and I have already changed it. Tks for all valuable advice.

Tks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.