Solved

Deferred Tx and Port Drops

Posted on 2011-09-29
10
3,142 Views
Last Modified: 2012-08-13
Hello i have two procurve switches connected with two Trunks (port channel) TRK1 is port 1 and 2 and TRK2 is port 23 and 24.

On port 1 and 2 i am noticing Deferred Tx: i checked the auto negotiation for all ports and these are all correct.

Port 22 of both Sw1 and Sw2 goes to another L3 switch which is Cisco, port 22 of Sw2 is down because of spanning tree.

Any ideas?  Show commands attached.


Show.txt
0
Comment
Question by:Jack-Black
  • 5
  • 5
10 Comments
 
LVL 3

Expert Comment

by:pistanu
ID: 36890572
on cisco ports:

spanning-tree bpdufilter enable

for errors check the flow control, it needs to be on both interfaceson/off not combination with one end on and the other off.

Deferred errors:

The deferred counter counts the number of times the interface has tried to send a frame, but found the carrier busy at the first attempt (Carrier Sense). This does not constitute a problem, and is part of normal Ethernet operation.
0
 

Author Comment

by:Jack-Black
ID: 36900185
I am adding the show interface of the CISCO port connecting to SW1, please note the pause input counters.


GigabitEthernet2/0/2 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 5835.d9a9.0c02 (bia 5835.d9a9.0c02)

  Description: SW1-Port22

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 76/255, rxload 19/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

  input flow-control is on, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:48, output hang never

  Last clearing of "show interface" counters 1d01h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 44884

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 74646000 bits/sec, 7536 packets/sec

  5 minute output rate 298541000 bits/sec, 28300 packets/sec

     1863976424 packets input, 2593355954882 bytes, 0 no buffer

     Received 189043 broadcasts (189038 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 189038 multicast, 33326 pause input

     0 input packets with dribble condition detected

     2083631112 packets output, 1973233746208 bytes, 0 underruns

 

0
 
LVL 3

Expert Comment

by:pistanu
ID: 36901928
pause input:

      Description: Cisco IOS show interfaces counter. An increment in pause input counter means that the connected device requests for a traffic pause when its receive buffer is almost full. Common Causes: This counter is incremented for informational purposes, since the switch accepts the frame. The pause packets stop when the connected device is able to receive the traffic.

did you try with flow control off? it's not a problem if you have this errors.so do you have problems with this links?

0
 

Author Comment

by:Jack-Black
ID: 36915340
Flowcontrol is on.
0
 
LVL 3

Expert Comment

by:pistanu
ID: 36915996
from your post:

input flow-control is on, output flow-control is unsupported
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:Jack-Black
ID: 36917504
Do you think the drops "Total output drops: 44884" and the "output flow-control is unsupported" are related.

The HP switches have flowcontrol enabled on the ports as far as i know it is enabled in and out by default.

What about the 33326 pause input?
0
 
LVL 3

Expert Comment

by:pistanu
ID: 36922651
i think so, try to enable on cisco output flow control ON, or put it off for every link cisco-hp
0
 

Author Comment

by:Jack-Black
ID: 36922670
can you give me the command to enable flowcontrol on the cisco out please
0
 
LVL 3

Accepted Solution

by:
pistanu earned 500 total points
ID: 36922806
on 3560 only receive flowcontrol  can be put on or off.
on 7600 you can put both(receive/send) to on or off.

in you case try to put off on cisco and on HP too.do you have graphs ont that ports?maybe in some peak time you're in congestion.
0
 

Author Comment

by:Jack-Black
ID: 36977903
Will try to get some graphs.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

919 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now