Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

could not allocate enough memory to initialize 'read only memory object

Posted on 2011-09-29
4
1,413 Views
Last Modified: 2012-08-14
I reset my memory settings on my SQL server 2000 Enterprise and now unable to start SQL service.

Event Type:      Error
Event Source:      MSSQLSERVER
Event Category:      (2)
Event ID:      17055
Date:            9/29/2011
Time:            3:45:44 AM
User:            N/A
Computer:      
Description:
17138 :
Could not allocate enough memory to initialize 'ReadOnly memory object'.


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: f2 42 00 00 10 00 00 00   òB......
0008: 09 00 00 00 52 00 4d 00   .....
0010: 47 00 45 00 5a 00 43 00  
0018: 41 00 50 00 00 00 00 00   ....
0020: 00 00                     ..      


0
Comment
Question by:onlinetechie
4 Comments
 
LVL 18

Accepted Solution

by:
x-men earned 500 total points
ID: 36814075
run sqlservr.exe -f

usage: sqlservr
        [-c] (not as a service)
        [-d file] (alternative master data file)
        [-l file] (alternative master log file)
        [-e file] (alternate errorlog file)
        [-f] (minimal configuration mode)
        [-m] (single user admin mode)
        [-g number] (stack MB to reserve)
        [-k <decimal number>] (checkpoint speed in MB/sec)
        [-n] (do not use event logging)
        [-s name] (alternate registry key name)
        [-T <number>] (trace flag turned on at startup)
        [-x] (no statistics tracking)
        [-y number] (stack dump on this error)
        [-B] (breakpoint on error (used with -y))
        [-K] (force regeneration of service master key (if exists))
0
 
LVL 15

Expert Comment

by:Anuj
ID: 36814171
What setting you did? did you reduced the memory consumption? please share more details.
0
 
LVL 5

Expert Comment

by:MrNetic
ID: 36814458
Could increase mem with -g384 flag :)
0
 

Author Closing Comment

by:onlinetechie
ID: 36818790
Thanks! issue resolved.

>> Restored the backup of the Master database.
>> Found that they have restored the master of some other instance and hence it was not able to find the database files in the location where it is supposed to be.
>> Requested to get back the original master files.
>> Then opened a command prompt and started the SQL Server in minimal configuration using -f.
C:\Program Files\Microsoft SQL Server\MSSQL\Binn>sqlservr -f
>> Connected from another command prompt using osql.
OSQL -S Machine Name -E
>> Ran the following command.
sp_configure 'Max Server Memory', 3078
Reconfigure with override
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Deploying a Microsoft Access application in a Citrix environment is not difficult but takes a few steps. However, Citrix system people are often of little help, as they typically know next to nothing about Access. The script provided here will take …
For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
Via a live example, show how to shrink a transaction log file down to a reasonable size.
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question