Solved

Application shuts down when mouse is moved

Posted on 2011-09-29
17
963 Views
Last Modified: 2012-05-12
We are having issues with the Centura application in Windows 7.  When the program is launched, the login box appears.  Once the mouse is moved to click in the login box, the application shuts down with the following error "Unrecoverable Error: This External Function can't be found.  Check the DLL and ordinal number"  We can logon if the mouse is not moved using the tab keys and the application opens up. But if the mouse is moved within the application i shuts down.  Our developers have take the application apart (DLL's registered, added) but no solution.
Thank you for any suggestions  
0
Comment
Question by:ELGowen
  • 9
  • 5
  • 3
17 Comments
 
LVL 30

Expert Comment

by:ded9
ID: 36814675
Create a new user account ...user account might be corrupted.

Launch the app in clean boot mode

Clean boot process

Start-type - msconfig- click on startup tab- click disable all...then click services tab- put a check on hide all microsoft services ...and then click disable all....click ok and then restart the computer in normal mode.

If everything works fine in clean boot then enable five startup items and services at a time to find the faulty software.




Ded9
0
 
LVL 23

Expert Comment

by:Brian B
ID: 36814745
Better yet, just start windows in safe mode. This will tell you if something third party to windows is causing the problem. Then you will know where to look in msconfig.
0
 

Author Comment

by:ELGowen
ID: 36902408
Application works fine with windows XP so no fault with the user account.

Starting in safe mode reveals no issues.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 30

Expert Comment

by:ded9
ID: 36902494
"Application works fine with windows XP so no fault with the user account"

User account gets corrupted because of faulty programs...did u try clean boot.

Can also try uninstalling your security software...reboot and check.



Ded9
0
 

Author Comment

by:ELGowen
ID: 36902556
The application will not work on any Windows 7 pc, we have tested many.  Have uninstalled security software.  Still no joy I'm afraid.
0
 
LVL 30

Expert Comment

by:ded9
ID: 36902738
Uninstall the application and reboot..

Now right click on the software setup file - properties- compatibility tab- select xp from the list and click ok....now try installing the app.





Ded9
0
 

Author Comment

by:ELGowen
ID: 36902794
The problem is the app is not installed on the pc.  It is launched by a shortcut to the .exe on the server.
0
 
LVL 30

Expert Comment

by:ded9
ID: 36903039
Disable UAC or lower down UAC setting from control panel...reboot the computer and check the exe app.



Ded9
0
 

Author Comment

by:ELGowen
ID: 36903136
UAC is at it's lowest setting.
0
 
LVL 30

Expert Comment

by:ded9
ID: 36903349
Disable uac and check.



Ded9
0
 

Author Comment

by:ELGowen
ID: 36903498
UAC disabled and rebooted.  Still no joy.
0
 
LVL 23

Expert Comment

by:Brian B
ID: 36903908
The program may simply not be compatible with Win7. Is your version on this list? I notice there is no Win7 column in a lot of the products...
http://www.unify.com/Products/App_Dev/TeamDeveloper/TeamDeveloperCompatibilityMatrix.aspx

So to that end, you could try XP compatibility mode.
0
 

Author Comment

by:ELGowen
ID: 36904107
Thats what we thought too however it also happens in XP compatibility mode,  but not when on the specific XP machines
0
 
LVL 23

Expert Comment

by:Brian B
ID: 36904957
It simply may not be compatible. I suppose if you are really stuck, you could set up a true VM with XP installed on the windows 7 machines (instead of compatibility mode). Or if this is something only some people use some of the time, set up a terminal server ($$$) or a couple of XP boxes ($) on a virtual machine that people can access when they need this program. Otherwise you might be out of luck.

You might be best to check with the vendor. They probably have more experience with their product in this situtation.
0
 

Accepted Solution

by:
ELGowen earned 0 total points
ID: 36990976
It turns out that there were two functions in the script referring to the mouse move. When these were commented out the application works fine.
0
 

Author Closing Comment

by:ELGowen
ID: 37013620
Solution found by software development team
0
 

Author Comment

by:ELGowen
ID: 36990988
Issue resolved
0

Featured Post

Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi Friends, These registry tweaks will help you optimizing your Windows 7 system for any VDI. This will improve the machine performanance and can be used on normal systems also. These are few registry tweaks which will add value by enhancing the …
OfficeMate Freezes on login or does not load after login credentials are input.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

815 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now