How to disable certificate notification when logging in as 2008 Terminal Services client?

Hi everybody,

We're currently on the verge of switching to our new terminal server far which uses Windows 2008 R2 and everything is fine except for one small detail. Currently we have a Connection Broker and TS Farm set up where when we log into the server farm address, it sends us to one of two terminal servers called TS006 and TS008 (names we have them).

Now the problem we're facing and can't seem to figure out is that despite creating a certificate and storing it in the "Trusted Root Certification Authorities" physical locations on each server, we continually receive a untrusted certificate notification every time we try to log into the terminal servers as a remote desktop services user (as shown in the photo attachment). The weirdest part is that every now again that notification will disappear when we try to log in and everything will work fine. But then soon after it comes back. Very strange.

Does anyone have any thoughts or knows how we can either do one of the following:

1) Disable the certificate notice for all remote desktop services users


2) Properly install the certificate where it needs to go so we can fix this

Thanks! Certificate notification error that we want to disable.  
Who is Participating?
penguinjasConnect With a Mentor Commented:
For answer 2. If this certificate is a self-signed cert is it from an Enterprise CA on your network?  If not the workstations connecting will not recognize the cert as valid no matter where you place it on the terminal servers.
Zoldy2000Author Commented:
Installed Valid Cert
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.