Solved

Block access to OWA in Exchange 2010 SP1 Hosting Mode

Posted on 2011-09-29
25
640 Views
Last Modified: 2012-05-12
Friends okay.

I'm trying to block access to OWA on my Exchange 2010 SP1 Hosting Mode.

I am using this command:

Set-CASMailbox -Identity adam@contoso.com -OWAEnabled:$true -POPEnabled:$true
Refer: http://technet.microsoft.com/pt-br/library/bb125264.aspx

But when I try to apply this command to the Domain User powershell returns me the error saying it could not find the object.

Thank you friends.
0
Comment
Question by:welltecnologia
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
  • 5
  • 4
  • +2
25 Comments
 

Author Comment

by:welltecnologia
ID: 36817288
hello, please...

0
 

Author Comment

by:welltecnologia
ID: 36817959
PLEASE.. hello....

Posted: 29/09/11 12:56 PM


0
 

Author Comment

by:welltecnologia
ID: 36890985
hello..... please...
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 37

Expert Comment

by:Jian An Lim
ID: 36891012
put -Organization TestOrg  at the end of your command
0
 

Author Comment

by:welltecnologia
ID: 36891037

Nothing, please... helpme..

Set-CASMailbox -identify 'user' -OWAEnabled:$false -Organization domain.com.br
0
 

Author Comment

by:welltecnologia
ID: 36891050
See the error:

[PS] C:\>Set-CASMailbox -identify user -OWAEnabled:$false -Organization domain.com.br
Não é possível localizar um parâmetro posicional que aceite o argumento 'user'.
    + CategoryInfo          : InvalidArgument: (:) [Set-CASMailbox], ParameterBindingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Set-CASMailbox

[PS] C:\>
0
 
LVL 37

Expert Comment

by:Jian An Lim
ID: 36891163
is identity  

not identify
0
 

Author Comment

by:welltecnologia
ID: 36891211
Ok, now no more the error, but the error at the end of this command, see:


[PS] C:\>Set-CASMailbox -identity 'user' -OWAEnabled:$false -Organization domain.com.br
Não é possível localizar um parâmetro posicional que aceite o argumento '-Organization'.
    + CategoryInfo          : InvalidArgument: (:) [Set-CASMailbox], ParameterBindingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Set-CASMailbox

[PS] C:\>
0
 
LVL 17

Expert Comment

by:James H
ID: 36891229
Organization is the name of the company "Comany Name" not the domain name.
0
 

Author Comment

by:welltecnologia
ID: 36891245
But alas, the error message is not the name of the organization but the code does not recognize it (Can not find a positional parameter that accepts the argument '-Organization. ")

The name of my own domain is the oganização.
0
 

Author Comment

by:welltecnologia
ID: 36891270
But alas, the error message is not the name of the organization but the code does not recognize it (Can not find a positional parameter that accepts the argument '-Organization. ")

The name of my organization's own domain.
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 36891297
Here is the documentation for the Set-CASMailbox http://technet.microsoft.com/en-us/library/bb125264.aspx

Your other alternative is to open up the Exchange Management Console, expand recipients and go into "mailbox options" and disable OWA access
0
 

Author Comment

by:welltecnologia
ID: 36891304
friend, we are talking about hosting exchange mode.
there is no console in this version.

exactly why is my difficulty.
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 36891314
Right! sorry, I'm only a couple sips into my first morning coffee my apologies.

Are you trying to disable it en masse for  anumber of users?

You could try something like the following http://dougg.co.nz/2011/03/15/disable-owa-in-bulk-for-exchange-2010/ 

0
 

Author Comment

by:welltecnologia
ID: 36891329
Okay, fine.

No, this my organization, I have 40 organizations.
But this is specific to only 200 users and 20 users will be blocked from using OWA.

But I can not run this command in powershell to block these 20 users.
0
 
LVL 17

Expert Comment

by:James H
ID: 36891337
For 'user' are you putting the full email address?  .... user@domain.com
0
 
LVL 16

Accepted Solution

by:
Auric1983 earned 500 total points
ID: 36891352
can you please try the following

Get-Mailbox –Organization “Org Name” –Identity “identity” | Set-CASMailbox -OWAEnabled:$false
0
 

Author Comment

by:welltecnologia
ID: 36891353
Yes.

only error now seems to be here:

(Can not find a positional parameter that accepts the argument '-Organization. ")

This command is wrong.
0
 
LVL 17

Expert Comment

by:James H
ID: 36891357
Sorry.. i see that you did try this.
How many Exchange shells do you have open?
I ran across something similar with the hosting where if there were too many shell sessions open, it would not load all of the shell commands.
0
 
LVL 17

Expert Comment

by:James H
ID: 36891367
Ignore Organization, this is not a usable parameter for this command.
0
 

Author Comment

by:welltecnologia
ID: 36891378
Perfect, You are amazing!

Unfortunately slow response, but that's OK, problem solved.

I can not imagine my life without the help of you ... thank you friends.
0
 
LVL 23

Expert Comment

by:yo_bee
ID: 36891420
@willtech

Sounds a bit ungrateful. Having your issue resolved in less than a day is not a bad turnaround time.
Could have left that part of the comment out if you are thankful.
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 36891426
Just remember with powershell you can pipe commands together to get the results you want.  

So if you have another "filter" that you can do a Get-Mailbox command on to get the list of all the users you want to deactivate, you can do that

For example

Get-Mailbox -Organization "Org Name" | Set-CASMailbox ...
0
 
LVL 16

Expert Comment

by:Auric1983
ID: 36891433
More than happy to help, but don't forget that EE is a community and most of the contributors have full time jobs as well.  I try to set aside a few minutes of each day to deal with queries but my paying job takes priority :)
0
 

Author Comment

by:welltecnologia
ID: 36891447
my goodness.

was a constructive and not destructive criticism.
not misinterpret me.

I am so very pleased with the solution of you, I said this because when we opened a doubt, just above the site says up to 31 minutes and answered the question so I would solve it almost 23 hours later.

I'm new here and thought that would be really repsostas within 31 minutes.

Congratulations to you all and may Necromancer, I will not manage any exchange without the help of you.

thanks for everything and sorry for my previous comment.
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question