Solved

update or install program in  suse 10 sp1 Enterprise

Posted on 2011-09-29
3
361 Views
Last Modified: 2012-05-12
Hi
We have one suse 10 sp1 enterprise server and we stoped paying suse..

I never worked on suse before and i need to install some program on it.

is there any free repo out there to get rpm for this ?

if yes, how do you add that repo in to suse ??

thanks

 
0
Comment
Question by:fosiul01
3 Comments
 
LVL 2

Accepted Solution

by:
Roy earned 400 total points
Comment Utility
SLES uses hashes to verify the update or install of any package; you may not be able to install rpm's not from the SLES repositories or CDs. You might want to give it shot with OpenSuse 10.2 Repos but there will be conflicts.

regarding adding repors is easy:


Listing Repos
#zypper lr
for adding:
# zypper ar "http://<<...>>" <reponame>
Remove Repo
# zypper rr <<reporname>>
Modify Repo
# zypper mr -d <<reponame>> ####disables the repo
# zypper mr -e <<reponame>> ####enables the repo
0
 
LVL 2

Assisted Solution

by:KishorDas
KishorDas earned 50 total points
Comment Utility
You can use compatible opensuse repositories. But as stated by root4u, there will be some library conflicts and of course you use the GUI Yast2 -> Software -> Installation Source     to add an remove repositories on sles10.

In my suggestion, it will be better you collect the source of the programs and compile them on your sles10 system. It will be safe but little bit difficult also.

Thanks
Kishor Kumar Das
0
 
LVL 5

Assisted Solution

by:hvillanu
hvillanu earned 50 total points
Comment Utility
Hi,

I don't recommend you use others "free" repos, I strongly reccomend you download the source packets from the developer's site and compile it for SLES from scratch.

-regards-
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now