Solved

Searching in "all mail items" does not work

Posted on 2011-09-29
7
313 Views
Last Modified: 2012-06-21
Hello,

My Outlook 2007 search works well in a specific folder. But it doesn't work for the "search all mail items" option. It never finds anything.

How can I fix this?

Gene Fox
0
Comment
Question by:GeneFox56
  • 3
  • 2
  • 2
7 Comments
 
LVL 7

Expert Comment

by:Christopher Martinez
ID: 36816823
Are you using the "instant search"?
0
 
LVL 7

Expert Comment

by:Christopher Martinez
ID: 36816832
Meant to add more to that, if you are do this Go to Control Panel -> Indexing Options -> Modify -> Click the mailbox that you are using. This will reindex the files. REboot outlook at that point and it may take awhile to index everything again, but hopefully this works.
0
 
LVL 8

Expert Comment

by:ConUladh
ID: 36817048
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:GeneFox56
ID: 36817098
Hello Bahpoopie,

Yes, I'm using the "instant search".

Why would that help. All my emails are indexed fine, because if I search from within a specific folder, it will instantly find the right (asked for) emails. The search is working well - but only within one folder at a time.

If there is a reason to reindex, I'll do it.

Gene

0
 

Author Comment

by:GeneFox56
ID: 36817116
Hello ConUladh,

I'm using Windows 7 Pro.

Again, the instant search works wonderfully for one specific folder at a time. But won't work for the "in all items" option.

Gene
0
 
LVL 8

Accepted Solution

by:
ConUladh earned 500 total points
ID: 36817164
Few options here, some are quick checks, other require a bit of work:

http://www.msoutlook.info/question/47
0
 

Author Closing Comment

by:GeneFox56
ID: 36817624
Thanks for the help.

I went to "Tools-> Options-> Search Options-> Index messages in these data files".

I had to options and they were both checked: "Outlook data file" and "Archive Folders".

I deselected "Archive Folders" and then restarted Outlook and It worked fine for the instant search with the "All Mail Items" option. So I reselected the "Archive Folders" and it continues to work fine.

I don't know what the problem was, but it seems to have fixed itself.

Thanks for you help.  Gene
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question