Solved

ESXi Host-Only vSwitch

Posted on 2011-09-29
5
2,316 Views
Last Modified: 2012-05-12
We have an ESXi 4.1 server that we created a new vSwitch on.  We want this vSwitch to be for a host only network.  No physical adapters have been added to this vSwitch.  We have three machines that we have added NICs tied to this new vSwitch and assigned static IPs to each.  We are using the 192.168.192.xxx/24 IPs.  We are not able to communicate via ping, unc path, or any other method between the machines.  Two of the machines are running Server 2008 Standard x64 with the Windows Firewall Disabled.  The other machine is running Windows 7 Pro x64 with Windows firewall disabled.

We need to get a host-only network set up for a virtual lab.  Is there something that I am mis-configuring or something that I am just missing?
0
Comment
Question by:mkrzeminski
  • 3
  • 2
5 Comments
 
LVL 118
ID: 36817047
If you have created a virtual switch e.g. vSwitch1, it's not uplinked to a physical network card in the host, and you have created a Virtual Machine Network port group, all the VMs are connected to this Virtual Machine Network, this is all that's required for communications to be established between virtual machines.

example, both VMs, vESXi 5.0 and Win2k8 Mem Test can access each other

 host only
0
 

Author Comment

by:mkrzeminski
ID: 36817117
That is exactly how I have it created.  I have attached a screen shot of the configuration.

 Network Configuration
0
 
LVL 118
ID: 36817150
That should work.

What NICS are being used in the VMs?

Have you confirmed by attaching to another network, that networking is OKAY.

Are the NICs connected, and connected at Power-OIN.

VMware Tools installed and VMXNET3 network card in use.
0
 

Accepted Solution

by:
mkrzeminski earned 0 total points
ID: 36817372
Everyone,
This ended up being a windows firewall problem.  The network was being flagged as a private network so the firewall enabled.  I had the firewall disabled for public and domain networks.  Thank you for your help.
0
 

Author Closing Comment

by:mkrzeminski
ID: 36908458
Was not a problem with the VMware configuration but was a problem with the windows firewall.
0

Featured Post

Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

HOW TO: Install and Configure VMware vSphere Hypervisor 6.5 (ESXi 6.5), Step by Step Tutorial with screenshots. From Download, Checking Media, to Completed Installation.
When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
Teach the user how to delpoy the vCenter Server Appliance and how to configure its network settings Deploy OVF: Open VM console and configure networking:
Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now