Solved

IIS7 New Website and Application and AJAX Controls

Posted on 2011-09-29
9
284 Views
Last Modified: 2012-05-12
A website was created using Visual Studio 2010 and published to a test Windows 7 machine. After verifying that the website is functional, the files and folders that makeup the website were copied (not published) to a Win 2008 R2 server (Std. Ed.) running IIS 7.5.7600.

On the Win 2008 server, I first created the subfolder C:\inetpub\wwwroot\nihi. The files and folders that makeup the website were copied from the Win 7 machine to the Win 2008 nihi subfolder. Then in IIS7 Manager (Win 2008), I right-clicked on DefaultWebSite, and clicked "Add Virtural Directory", creating a virtual that points to C:\inetpub\wwwroot\nihi. The name I gave the virtual was nihiweb. Next in IIS Mgr, I right-clicked on the nihiweb virtual, and clicked "Convert to Application". While in IIS Mgr, I switched to "Content View", selected nihiweb in the left-hand pane, then right-clicked on Default.aspx, and clicked Browse. This launched IE and allowed me to successfully view and navigate thru the website.

But it is not desirable for me to have nihiweb under DefaultWebSite. So in Windows Explorer (of the same Win 2008 server), I created C:\Website\nihi. I copied all the files and folders from the Win 7 machine over to C:\Website\nihi. Then in IIS Mgr, I right-clicked Sites, and created a new website called NihiWebSite. Then I repeated all the steps above where I created a new virtual under NihiWebSite, and converted the virtual to an application. But in IIS Mgr, when I select nihiweb under the NihiWebSite, right-click on Default.aspx, and click Browse, all of my AJAX-type controls do not respond to user interaction. It's like they are frozen.

I am having trouble finding the cause of this problem. I have compared all the property settings between DefaultWebSite and NihiWebSite. I have compared the application properties for nihiweb under DefaultWebsite vs. nihiweb under NihiWebSite. I've made sure that the app pools are compatible. I've used Win Explorer to compare user and permissions between C:\inetpub\wwwroot\nihi and C:\Website\nihi.

Does anybody have a checklist that I can follow to try to determine what is wrong with my new website and web app settings? Please, any suggestions?

Thank you
0
Comment
Question by:brian_appliedcpu
  • 4
  • 3
  • 2
9 Comments
 
LVL 40

Expert Comment

by:Kyle Abrahams
ID: 36817206
You shouldn't need to create a virtual directory under the Nihi website.  You should just be able to browse.  also make sure you have all of your isapi filters enabled.

0
 
LVL 11

Expert Comment

by:G_H
ID: 36817385
Hi,

You have also not mentioned anything about "host header values", what name are you trying to run this under?

GH
0
 
LVL 2

Author Comment

by:brian_appliedcpu
ID: 36817529
OK, so I did away with nihiweb located under the nihiwebsite and I now have the nihiwebsite pointing directly at my web app (I have assigned a host header). But my result is the same; all ajaxified controls are non-responsive.

I have standard ASP.NET controls on the web pages, such as dropdownlist, and command buttons, and they all function fine. But any ajax controls do not respond to user input / interaction.

So what about these isapi filters? Isn't an "installed" filter the same as an "enabled" filter? In IIS mgr at least, I don't see where to go about enabling / disabling an isapi filter.
0
 
LVL 11

Expert Comment

by:G_H
ID: 36817914
Can you check the logfiles for the new site, and see if the Server part of the ajax is actually being called (and returns 200)..

GH
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 2

Author Comment

by:brian_appliedcpu
ID: 36910120
this problem seems to only occur when browsing the site from the same server that is hosting IIS. The problem does not occur when accessing the site from the internet (and I think this is true from other machines within the intranet, but haven't fully tested that).
0
 
LVL 40

Expert Comment

by:Kyle Abrahams
ID: 36910298
are you browsing using localhost?

What if you hit the website from the server using the full website name?
0
 
LVL 2

Author Comment

by:brian_appliedcpu
ID: 36911495
same problem when using localhost or the Internet URL.
0
 
LVL 40

Accepted Solution

by:
Kyle Abrahams earned 500 total points
ID: 36917946
Did you try adding the site to the trusted sites in the browser on the server?  Also ensure you have javascript full enabled as well as the .net frameworks installed.

The browser security is a bit tricky when using the server.
0
 
LVL 2

Author Closing Comment

by:brian_appliedcpu
ID: 37039678
h
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
Lync server 2013 Backup Service Error ID 4049 – After File Share Migration
The purpose of this video is to demonstrate how to set up the WordPress backend so that each page automatically generates a Mailchimp signup form in the sidebar. This will be demonstrated using a Windows 8 PC. Tools Used are Photoshop, Awesome…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now