Link to home
Start Free TrialLog in
Avatar of it-rex
it-rex

asked on

AIX list offset logical volume created with mklv -TO -t raw

3.Find the number of partitions per disk in the volume group

3.3.Find the number of partitions per disk in the volume group
# lsvg -p cert_asmvg1
cert_asmvg1:
PV_NAME           PV STATE          TOTAL PPs   FREE PPs    FREE DISTRIBUTION
hdisk17           active            7           7           02..01..01..01..02
hdisk18           active            7           7           02..01..01..01..02

4.Create a single zero-byte offset logical volume for each physical volume using up all space on that physical volume. The suggested naming standard is <db_name>_asmdisk<seq>
# mklv -TO -t raw -U oracle -G dba -P 600 -y cert_asmdisk1 cert_asmvg1 7 hdisk17
cert_asmdisk1
# mklv -TO -t raw -U oracle -G dba -P 600 -y cert_asmdisk2 cert_asmvg1 7 hdisk18
cert_asmdisk2


===how can I list the offset logical volume  I have just created  cert_asmdisk2
Avatar of it-rex
it-rex

ASKER

to be more clear I have setps 3,4
and my Question is

How can I list the offset logical volume  I have just created  cert_asmdisk2?
ASKER CERTIFIED SOLUTION
Avatar of woolmilkporc
woolmilkporc
Flag of Germany image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Content?

The first ten 80-byte blocks:

dd if=/dev/rcert_asmdisk2 bs=80 count=10

In char and hex:

dd if=/dev/rcert_asmdisk2 bs=80 count=10 | od -tcx
Avatar of it-rex

ASKER

under /dev

brw-------    1 oracle   dba          37,  1 Sep 29 14:25 cert_pidisk1
brw-------    1 oracle   dba          37,  2 Sep 29 14:25 cert_pidisk2
crw-rw----    1 root     system       37,  0 Sep 29 13:20 cert_pivg1
crw-------    1 oracle   dba          37,  1 Sep 29 14:25 rcert_pidisk1
crw-------    1 oracle   dba          37,  2 Sep 29 14:25 rcert_pidisk2


the commands used to create

cert_pidisk1
cert_pidisk2

are

mklv -TO -t raw -U oracle -G dba -P 600 -y cert_pidisk1 cert_pivg1 1199 hdisk4
mklv -TO -t raw -U oracle -G dba -P 600 -y cert_pidisk2 cert_pivg1 199 hdisk5

I do not see in the docs how

rcert_pidisk1
rcert_pidisk2

were created

if I do
 lslv cert_pidisk1

I get

LOGICAL VOLUME:     cert_pidisk1           VOLUME GROUP:   cert_pivg1
LV IDENTIFIER:      00c1c87500004c0000000132b6334d48.1 PERMISSION:     read/write
VG STATE:           active/complete        LV STATE:       closed/syncd
TYPE:               raw                    WRITE VERIFY:   off
MAX LPs:            1199                   PP SIZE:        256 megabyte(s)
COPIES:             1                      SCHED POLICY:   parallel
LPs:                1199                   PPs:            1199
STALE PPs:          0                      BB POLICY:      relocatable
INTER-POLICY:       minimum                RELOCATABLE:    yes
INTRA-POLICY:       middle                 UPPER BOUND:    1024
MOUNT POINT:        N/A                    LABEL:          None
MIRROR WRITE CONSISTENCY: on/ACTIVE
EACH LP COPY ON A SEPARATE PV ?: yes
Serialize IO ?:     NO
DEVICESUBTYPE : DS_LVZ
COPY 1 MIRROR POOL: None
COPY 2 MIRROR POOL: None
COPY 3 MIRROR POOL: None

but when I do

$ lslv rcert_pidisk1
0516-306 lslv: Unable to find  rcert_pidisk1 in the Device
        Configuration Database.



what I am missing and what is the difference between both?
cert_pidisk1

is the name of the logical volume you created and also the name of the associated block device special file (driver).

rcert_pidisk1

is the name of the automatically generated "character" ("raw") device special file (driver) for that LV.

Please see the letters "c" ("character" = "raw") and "b" ("block") in the first column of the "ls -l /dev/..." output.

See also the major and minor numbers of the devices (37 / 1 for (r)cert_pidisk1, 37 / 2 for (r)cert_pidisk2).

They're identical for "cert..." and "rcert..." so you can see that it's the same device and just a different driver.

wmp


Avatar of it-rex

ASKER

you are athe best!