Solved

Windows 7 ask for login credentials on Server 2008R2. XP client's connect OK

Posted on 2011-09-29
8
306 Views
Last Modified: 2012-05-12
Have a new Windows 7 Professional (32 bit) PC trying to connect to Windows 2008R2 Server (not AD). When I dbl click on server name, I get asked for user name & PW. Windows XP PC's don't ask for this. I've gone to sharing options on this PC and turned off password protected sharing for home and public profile. I've turned off firewall on the server just to check.

All PC's are on the "Workgroup" work group. I've disjoined the workgroup and rejoined it and still asks for user name and password.
0
Comment
Question by:ChazNTroy
  • 4
  • 2
  • 2
8 Comments
 
LVL 4

Expert Comment

by:rar3z
ID: 36818667
One solution you can do is.. the username and password that you are logged into the windows 7 pc, you can use the same username and credentials on the server (create a user in the server with those credentials) and allow that newly created user to access the file/folder you are trying to access.

That should solve your problem.
0
 
LVL 1

Author Comment

by:ChazNTroy
ID: 36818672
The application that I'm running cannot connect using login credentials. It has to have an open share.
0
 
LVL 6

Expert Comment

by:penguinjas
ID: 36818689
I believe the answer you want is at this link.   I had to make a simliar change to get Windows 7 to connect to a samba server.

http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/68ffbe2a-09a7-4e29-859c-ca1aaf75dcd1
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:ChazNTroy
ID: 36818698
Penguinjas - bad link. Get runtime error when link is opened. Try again please...

Thanks!
0
 
LVL 4

Expert Comment

by:rar3z
ID: 36818699
0
 
LVL 1

Author Comment

by:ChazNTroy
ID: 36818832
rar3z - this totally disabled my ability to even see the Windows 2008R2 server! Not cool :( ....
0
 
LVL 6

Accepted Solution

by:
penguinjas earned 500 total points
ID: 36819059
Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

-Enable network discovery
-Turn on  file and print sharing
-Turn off password protected sharing
-Use user accounts and passwords to connect to other computers

The other settings such as encryption I have set as use 128 bit encryption.

Please check related policies.

1. Enter “gpedit.msc” in the Start Search box.
2. Open “Computer Configuration”/Windows Settings/Security Settings/Local Policies/Security Settings.
3. In the right pane, enable the following policies:

Network access: Allow anonymous SID/name translation
Network access: Let Everyone permissions apply to anonymous users

Also please disable the following policies.

Network access: Restrict anonymous access to Named Pipes and Shares
Network access: Do not allow anonymous enumeration of SAM accounts
Network access: Do not allow anonymous enumeration of SAM accounts and shares
0
 
LVL 1

Author Closing Comment

by:ChazNTroy
ID: 36893010
Eventually I muttered through this solution off of a few other websites. You put this together in one place and hope that this helps others. Wonder what Windows 8 is going to do for this type issue? Can't wait...

Thanks!
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

FIPS stands for the Federal Information Processing Standardisation and FIPS 140-2 is a collection of standards that are generically associated with hardware and software cryptography. In most cases, people can refer to this as the method of encrypti…
Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question