Solved

Paypal error after change from PHP FastCGI to PHP ISAPI

Posted on 2011-09-30
4
379 Views
Last Modified: 2012-06-22
Hi all,

Need some help here. I am running on PHP 4.3.4 Fast CGI for my e-commerce platform which uses Paypal as a gateway.

However, due to the instability of FastCGI, I have switched to ISAPI and all functions can work except Paypal.

Can I ask whether there is a difference if I use FastCGI or ISAPI for Paypal?

I attached the code we used which is successful when using under FASTCGI but fails under ISAPI.
expresscheckout.php
0
Comment
Question by:cq27
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 110

Expert Comment

by:Ray Paseur
ID: 36891269
PHP 4.3.4

You have to fix that.  There is no support at all for PHP4 any more.  In fact, the PHP.net web site says this: All PHP users should note that the PHP 5.2 series is NOT supported anymore. All users are strongly encouraged to upgrade to PHP 5.3.8.

The upgrade is not optional; it is required and unfortunately it may be a big project.  In addition to the script attached to this question you will almost certainly need to refactor the code in this thing.
require_once ("paypalfunctions.php");

There are some resources that can help.  
https://www.x.com/developers
http://us2.php.net/manual/en/migration53.changes.php
0
 

Accepted Solution

by:
cq27 earned 0 total points
ID: 36894852
Hi all,

While waiting for the answer, I have checked on online forums and discovered the error was just a simple solution.

I needed to activate the CURL setting in ISAPI. After a test, it works fine now. There is no need to upgrade to PHP5.3.8 as Paypal originally worked fine in PHP434, just that I switched between FastCGI and ISAPI.
0
 

Author Closing Comment

by:cq27
ID: 36915558
I discovered the solution on my own via online forums.
0
 
LVL 110

Expert Comment

by:Ray Paseur
ID: 36895236
There is no need to upgrade to PHP5.3.8

Uhh?

No offense meant... you can do whatever you want; it's not my problem.  But I would fire a programmer who saw the PHP.net home page and then told me something like that.  The lack of understanding about the PHP4 security implication alone is sufficient to terminate for cause.
0

Featured Post

Ready to get started with anonymous questions?

It's easy! Check out this step-by-step guide for asking an anonymous question on Experts Exchange.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Password hashing is better than message digests or encryption, and you should be using it instead of message digests or encryption.  Find out why and how in this article, which supplements the original article on PHP Client Registration, Login, Logo…
There are times when I have encountered the need to decompress a response from a PHP request. This is how it's done, but you must have control of the request and you can set the Accept-Encoding header.
Learn how to match and substitute tagged data using PHP regular expressions. Demonstrated on Windows 7, but also applies to other operating systems. Demonstrated technique applies to PHP (all versions) and Firefox, but very similar techniques will w…
Viewers will get an overview of the benefits and risks of using Bitcoin to accept payments. What Bitcoin is: Legality: Risks: Benefits: Which businesses are best suited?: Other things you should know: How to get started:

634 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question