Attachemnts are not visible via oultook but there are visible via OWA. Exchange 2010

Hello All,
I have an exchnage 2010 SP1 and i have also installed the latest rollup 4 that was issued on 27/07/2011. The issue that we are facing is that many senders send messages with attachements and the attachements are not visible neither from outlook 2007 nor from outlook 2003, but the strange thing is that when i connect to mailboxes via OWA the attachments are visible. Also, when i forward them from owa then the user can read the attachements from their mailboxes. As i have read and understood the issue is not coming from outlook version but from the exchange server. Is there any solution or an effective workaround for this issue?
thank you in advance..

Who is Participating?
Jian An LimConnect With a Mentor Solutions ArchitectCommented:
try rollup 5

but again, i doubt it is a exchange server issue more than Outlook issue.

and there is a settings PR_ATTACHMENT_HIDDEN MAPI property (0x7FFE000B)  that can be hidden when send out document.

Do you have this on every attachments or certain attachment?
pad_petAuthor Commented:
Thank you for your reply, no i do not have it on all attachements, espeacially to word or excel files and always from the same sender. The strange thing is that when i receive a message with a hidden attachment and i forward the message to an external mail acount i.e. gmail, yahoo,etc the attachement is visible. Also, if i forward back the forwarded email from the extranal account to my coroporate mail the attachemnt is visible.
That is the why i believe that the issue comes from the exchange and not from outlook.
Thank you.
I am waiting your reply.
pad_petAuthor Commented:
limjianan also can you explain the setting PR_ATTACHMENT_HIDDEN MAPI ?
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

Jian An LimSolutions ArchitectCommented:

please download the tools

PR_ATTACHMENT_HIDDEN can be set to true, and in this case, it will be hidden from outlook (but owa will be visible)

some outlook addon may affect this setting but i am not sure.
pad_petAuthor Commented:
HI Limjianan,
thank you for above solution to my issue.
This wordaroun is working fine, but it is not a permanent solution.
Is it any way to change this for all messages that i will face the same issue?
Thank you again.
Jian An LimSolutions ArchitectCommented:
i have been thinking about the problem and understand what really happen.

unless you could find the root cause, i doubt i can help much as the issue is much rely on a faulty addon that decide to turn the pr_attachment_hidden on ...
maybe an AV?

but i highly doubt it is a exchange roll up issue.
Jian An LimSolutions ArchitectCommented:
i would like to advise that there is a similiar issue happen on another post which i am working on.

it could potentially for a message that includes an inline attachment from Microsoft Exchange Server

but again, i would like you to confirm this issue whether it has been happening.

Open in new window

pad_petAuthor Commented:
Dear All,
FInally, i installed the latest rollup 5 and the hidden attachemnts are now visible.
Thank you all of you for your help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.