Posted on 2011-09-30
Last Modified: 2013-12-27
user service account can't access ftp


Open in new window

how can i troubleshoot it???
Question by:cismoney
  • 5
  • 3
LVL 68

Expert Comment

ID: 36890631
What is the error message?

Do other users have access via FTP? If they don't the FTP service might not be started!

Does the home directory /app/facts/sm/ftp/br80/old_stats exist?

Is it accessible by old_stats?

Is old_stats perhaps present in /etc/ftpd/ftpusers? This file is meant to block users, not to allow access!

Do you use the standard Solaris FTP server or some third-party product?



Author Comment

ID: 36890658
the user is not present in /etc/ftpd/ftpusers.

the home directory  /app/facts/sm/ftp/br80/old_stats exist

Other users can have acces via ftp

i use standard solaris ftp

here is the error i get

# ftp old_stats
old_stats: unknown host or invalid literal address

Open in new window


Author Comment

ID: 36890706
service ftp is online, i don't understand whats goin on

# svcs -a |grep ftp
online         Apr_21   svc:/network/ftp:default

Open in new window

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.


Author Comment

ID: 36890770
Sorry I just found out other users can't login expect root. all the users get the same error

unknown host or invalid literal address
LVL 68

Accepted Solution

woolmilkporc earned 500 total points
ID: 36890783
old_stats is a userid, not a host. Use

ftp hostname

and wait for the prompt to log in as old_stats,

Author Comment

ID: 36890789
here is the output

# ftp hostname
hostname: unknown host or invalid literal address

Open in new window

LVL 68

Expert Comment

ID: 36890799
With 'hostname' I meant the name of your FTP server, not literally 'hostname'!

Author Comment

ID: 36891979
sorry  . the  user just forgot his password lol. Thanx for your help

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
sudo logging 5 101
help pulling data string using Awk 9 79
How to clone solaris 10 machine 33 149
lunix and unix command 21 89
Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question