Solved

How to configure asa 5505 to support multiple internal network segments?

Posted on 2011-09-30
9
1,051 Views
Last Modified: 2012-05-12
This is a newly bought Cisco ASA 5505 firewall. This is using ASA Version 8.4(2). Due to licensing, I found that it only allow to create 2 nameif - inside and outside, and Ip addresses not able to assigned to the physical ethernet interfaces. My network has 2 internal network segments - 10.0.1.x/24 and 10.0.2.0/24, and of course 1 external port to connect to router.

So, I configured vlan 2 interface with nameif outside, and assigned ethernet 0/0 to it. I configured vlan 1 interface with nameif inside, and assigned ethernet 0/1 and 0/2 to it. but, then how can I support both internal network segments on INSIDE?

thanks in advance.
0
Comment
Question by:MezzutOzil
  • 4
  • 4
9 Comments
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36890641
Well, using a base license you can have a third interface/vlan. This is limited though, it can only communicate with one other vlan. But if you don't need the two networks to communicate with each other you could still use the third vlan for internet access.
0
 

Author Comment

by:MezzutOzil
ID: 36890680
Hi einiebeek,

Can you show me the configurations?
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 36890695
Or super net 10.0.1.0/24 and 10.0.2.0/24 on the ASA and use 10.0.0.0/22 on the inside interface of the ASA
0
 

Author Comment

by:MezzutOzil
ID: 36890709
Hi RPPreacher,

How about the default gateway for segment 1.0/24 and 2.0/24?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36890710
@RPPreacher: thought of that, but what are you going to use as default gateway(s) on both the networks?

@MezzutOzil: see if this works:
interface Vlan 1
nameif inside
security-level 100
ip address 10.0.1.254 255.255.255.0
interface Vlan 2
nameif inside2
security-level 100
ip address 10.0.2.254 255.255.255.0
interface Vlan 3
nameif outside
security-level 0
ip address x.x.x.x 255.255.255.x
object network obj_any
subnet 0.0.0.0 0.0.0.0
nat (inside,outside) dynamic interface
0
 

Author Comment

by:MezzutOzil
ID: 36890732
Hi erniebeek,

I think the licensing only allow up to 2 nameif. When I wanted to create the 3rd nameif on new vlan, the following error prompted:

  This license does not allow configuratng more than 2 interfaces with nameif and without a "no forward" command on this interface or on 1 interface with nameif already configured.
 
0
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 500 total points
ID: 36890914
Ok, minor adjustement:

interface Vlan 1
nameif inside
security-level 100
ip address 10.0.1.254 255.255.255.0
interface Vlan 2
no forward interface vlan 1
nameif inside2
security-level 100
ip address 10.0.2.254 255.255.255.0
interface Vlan 3
nameif outside
security-level 0
ip address x.x.x.x 255.255.255.x
object network obj_any
subnet 0.0.0.0 0.0.0.0
nat (inside,outside) dynamic interface
0
 

Author Closing Comment

by:MezzutOzil
ID: 36904579
Excellence, it works
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 36904912
Good!
Glad I could help and Thx for the points :)
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
reserve ip based on mac addresses 6 105
Radius Debug Error 16 54
Cost effective dual wan w/ qos 5 27
Website Issue 10 63
Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now