Windows 2003 Server - File Sharing

Hi,

Need help with network file sharing. We have Windows network with XP clients and Windows 2003 Server for sharing data over the network

Scenario:

Server is called 'File-Server'
Share directory called 'Accounts' with sub-directories: Costing, Budget, Invoicing
3 Security Groups: Group A, Group B, Group C

Group A & B have full rights to the 'Accounts' folder and its sub-directories
Group C has only 'Read' access to the 'Accounts' folder and its sub-directories

I now want to give 'Group C' full rights to the Invoicing sub-directoy only.

Can someone point me in a right direction?

Many thanks,  
AKTII-UKAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
peter197911Connect With a Mentor Commented:
One question first.
How do you browse to the other shares.

\\file-server\accounts     --> and then choose the folder you need   or
are the other subfolders shared directly.
I'll describe thefor me, the most preferable option.

d:\ accounts   should have:    Share permissions for Domain users (full control)
                                                NTFS permissions on d:\accounts for Group A+B (full control)
                                                NTFS permissions on d:\accounts for Group C  (Read only)
                                                NTFS permissions on d:\accounts\invoice for Group C (full control)

voila.
0
 
Krzysztof PytkoSenior Active Directory EngineerCommented:
Where is this "Invoicing" sub dir ?
You can use "Advanced" options to grant them rights. Go to that folder, choose "Properties" and then "Advanced". From the list choose GroupC, grant them Modify rights and change scope to "This folder and files only"

Do not grant them Full Control, they would be able to change ACL and grant access to lower folders for themselves.

Permissions
Regards,
Krzysztof
0
 
bright12Commented:
Select the sharing tab of the Invoicing folder. Select then Group C and give them full rights.

This should do the trick.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
AKTII-UKAuthor Commented:
thanks for you response, i've tired both of yours suggestion but it still becomes read only
0
 
Krzysztof PytkoSenior Active Directory EngineerCommented:
Check if you have no "Deny" permission for write/change inherited from other level ?
From my attached screen select also "Apply these .... " and check again

Krzysztof
0
 
bright12Commented:
OK. Select the invoice folder and right click on it.
Select then Sharing and Security..

Click on the Permissions button.

Select now group c and check the Full Control option to Allow.
Click Apply -> OK -> Apply -> OK

This should work
0
 
AKTII-UKAuthor Commented:
Hello Peter,

the shares are accesed via  \\file-server\accounts     --> and then choose the folder you need

i'll try your method now and let you know what happens.
0
 
AKTII-UKAuthor Commented:
Thanks to everyone for your suggestion
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.