Solved

VRF on 7206

Posted on 2011-09-30
4
1,140 Views
Last Modified: 2012-06-27
Good Morning!

I'm in the process of re-doing our network at our headquarters, and have a question that is a bit above me in terms of my Cisco studies (Third of my way through CCNP). The 7200 is doing some VRF stuff that I'm not sure how/why/whats happening with it. I'll provide the setup and some config. The 7200 was set up before I was employed here.

Setup:
Time Warner Fiber. They gave us 2 subnets of IPs.
1st - 24.3*.**.56/30
2nd - 24.3*.**.48/29

ASA IP is 24.3*.**.50 using a GW of .49

(Time Warner Media Box) -> (7200) --> (ASA 5510) -local net

The 7200 is using the first range, the ASA is using the 2nd range. I want to remove the 7200 once these last few T1 offices convert over to faster connections. Here is the 7200 config.
Partial config: (Try to edit everything out that wasn't necessary).
ip vrf TWTELECOM
 rd 65535:100
 route-target export 65535:100
 route-target import 65535:100
!
interface FastEthernet0/0
 description TWTELECOM UPLINK
 ip vrf forwarding TWTELECOM
 ip address 24.3*.**.58 255.255.255.252
 load-interval 30
 duplex full
!

interface Ethernet4/1
 description PRL PIX CONNECTION
 ip vrf forwarding TWTELECOM
 ip address 24.3*.**.49 255.255.255.248
 ip nat outside
 duplex full
!

ip route vrf TWTELECOM 0.0.0.0 0.0.0.0 24.3*.**.57
ip route vrf TWTELECOM 24.39.83.24 255.255.255.248 24.3*.**.50

Open in new window


I guess my main question is.. what is this really doing? If I removed this box, what would/should I replace it with?
0
Comment
Question by:prlit
  • 2
  • 2
4 Comments
 
LVL 18

Accepted Solution

by:
jmeggers earned 500 total points
ID: 36892857
It doesn't seem to make a lot of sense that you would have a single VRF configured, unless there's a reason to separate VRF traffic from global traffic.  But it appears to me that you're just routing through the 7200 and the VRF isn't really providing you any benefit, unless there's some reason I can't think of why the ISP wants it set up that way.  Is the 7200 your router or managed by the ISP?
0
 
LVL 1

Author Comment

by:prlit
ID: 36893059
The 7200 is our router, however when Time Warner came through they requested to make those changes apparently for which ever reason. I'm not sure why they'd want or need to make the changes.. The only thing I can think of is if they can only give out a max /29?? Implemented the vrf and used the /30 to handle the gateway or something?

We literally use the 7200 for nothing except T1 offices entry/endpoint. Everything else is handled through the ASA. I want the 7200 out of there ASAP since it only has half duplex cards in it and it's a waste of our fibre speeds. I was just going to put in an L3 switch (I'm actually going to test that tonight when theres downtime).. I guess in the long run I'll probably have to call them and see if we actually need that setup as it is now..

My other question is, what exactly are the benefits of VRF in general. I've read some stuff about it, but haven't dived to much into it.
0
 
LVL 18

Expert Comment

by:jmeggers
ID: 36894029
The ASA won't handle a T1 interface, but likely neither would the L3 switch you're referring to.  Is T1 capability a requirement?

I see no need for the VRFs, the 7200 would route between the two subnets without any problem anyway.  But if it's there and working I certainly wouldn't mess with it just to get rid of the VRF.  If you don't need to support a T1 interface and can accept an Ethernet handoff, then just go straight to the ASA.
0
 
LVL 1

Author Comment

by:prlit
ID: 36894198
The T1s are scheduled to expire in November, and Time Warner is supposedly doing construction next week to bring these remote sites cable broadband (they're in no mans land, haha). So once they are set and good, thats when I was planning on moving the new equipment in and taking the 7200 out.

Thanks!
0

Featured Post

New! My Passport Wireless Pro Wi-Fi Mobile Storage

Portable wireless storage to offload, edit, and stream anywhere.

High-capacity, wireless mobile storage designed to accompany professional photographers and videographers in the field to easily offload, edit and stream captured photos and high-definition videos.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Network ports are the threads that hold network communication together. They are an essential part of networking that can be easily ignore or misunderstood, my goals is to show those who don't have a strong network foundation how network ports opera…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now