[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 567
  • Last Modified:

RBL and Exchange 2007

I have a hand full of users that have outside reciepents that bounce back emails sent to them and the error details note 'Message rejected because of RBL policy'

We are running Exchange 2007 and using Vipre (from GFI) for spam filtering. When I run our mail server IP on the blacklist check found at http://www.mxtoolbox.com it comes back clean.

My question is two fold...

(1) Could it be that we are listed someplace else that http://www.mxtoolbox.com does not scan again and if so is there another tool I should be using other than http://www.mxtoolbox.com?

(2) I am under the assumption that I am only relying only on GFI's software for RBL purposes but is it possible that I have it also setup in Exchange? If so how would I check?

Not sure if it matters any but the bounce backs all seem to come from users that have Google for email
0
bnrtech
Asked:
bnrtech
  • 11
  • 8
3 Solutions
 
Alan HardistyCommented:
What is the FQDN on your SEND Connector and what is your Reverse DNS Record on your fixed IP Address set as?

Do they match?  Do they both resolve in DNS back to the IP Address you are sending from?

If you are not sure - send me a test message to alan @ it-eye.co.uk and I'll see what you are sending as, what IP you are coming from and I'll see if I can see any issues with your setup that might be causing you problems.
0
 
Alan HardistyCommented:
FYI - Vipre is Anti-Virus not Anti-Spam.  Are you using GFI Mail Essentials for Spam Filtering?
0
 
bnrtechAuthor Commented:

Thanks for this input. I will send you a test email right now from the admin account. I did update the FQDN in E2007 a couple of moments ago. I thought I already did this but it looks like I was wrong in that assumption.

The Vipre product we use is both for anti-spam and anti-virus.

Thanks for this helpful input.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
bnrtechAuthor Commented:

FYI - Here is the Vipre product that we use...

http://www.gfi.com/mes

0
 
Alan HardistyCommented:
Ooh - sorry about the Vipre - didn't know they did a combined product.  We use a Vipre based solution from them and wrongly assumed it was only AV!  You live and you learn :)
0
 
Alan HardistyCommented:
Okay - test email received.  Checking your config to see if anything stands out as being wrong.
0
 
bnrtechAuthor Commented:

All good. Standing by. Thanks :)
0
 
Alan HardistyCommented:
Okay - your FQDN = exchange.domain.org.  Your Reverse DNS on the IP you are sending from is mail.domain.org.

Performing an nslookup on exchange.domain.org fails, so you would be better off changing the FQDN on your SEND connector to mail.domain.org then you will be RFC compliant.

Separate note - you have two MX records pointing to the same IP Address, which is completely pointless.  If you only have 1 server - having two MX's is not going to help if your 1 server goes down.  Best to remove the MX record with the 300 priority.

You don't have an SPF record and would be advised to get one setup.

Other than that - you are clean!
0
 
bnrtechAuthor Commented:
On the FQDN, maybe I need to restart the connector before the change takes effect (?). I will do that later and send you another test. I see your point in making certain both are mail.domain.org

Understood on the MX record.

Any recommendation on setting up a SPF record?

Thanks for all of the support
0
 
Alan HardistyCommented:
Make the change and restart the Exchange Transport Service.

You can visit http://www.microsoft.com/mscorp/safety/content/technologies/senderid/wizard/ to figure out what you need for SPF.

You are welcome :)
0
 
bnrtechAuthor Commented:

All good. I will restart the transport now and send you one more test message.
0
 
Alan HardistyCommented:
Okey dokey.
0
 
Alan HardistyCommented:
Still seeing exchange.domain.org as FQDN.
0
 
bnrtechAuthor Commented:

Maybe I need to reboot the server (which I can do tonight)?

and/or

Maybe I am not doing the right thing to setup the FQDN? Here are screenshots of the connectors with what I think is the right FQDN setup, Is there something I am missed? connector 1 connector 1connector2.JPG
connector3.JPG
0
 
Alan HardistyCommented:
You don't need to adjust your Receive connector - you need to adjust you Send Connector under Org Config> Hub Transport
0
 
bnrtechAuthor Commented:

Got it. My mistake. I just updated (hopefully the right way this time) and resent another test.

Thanks for all the good tips.
0
 
Alan HardistyCommented:
That's better.  Seeing mail.domain.org now.

Try sending emails to the recipients that failed before.
0
 
bnrtechAuthor Commented:
Thanks for all the help info!
0
 
Alan HardistyCommented:
Thanks for the points :)

Have a good weekend.

Alan
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 11
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now