Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 852
  • Last Modified:

Sharepoint 2007 - Crawl stop working 4 weeks ago

on the search setting I get this :
Propagation status: Query server not responding  Server4

I did restart all the servers, reset the crawl, restart a full crawl... not working again...

I have 4 server in farm, The Server4, I check on it and cannot see anything wrong... but again, my knowledge of sharepoint is limited.

thanks for your advise and help
0
altzar
Asked:
altzar
  • 9
  • 6
2 Solutions
 
GeorgeGerguesCommented:
That is very hard to debug
but I do reommend that you check the Crawl log and check that everything is crawled ok and you don't have Crawl Access issues for example.

If you want to debug the problem with index propagation , this should show more information under you windows application log.

Also you can run this stsadm command

from the command prompt at the Bin folder or if you have Bin folder on path .
stsadm -o osearch -action start


Read more about those commands here
http://technet.microsoft.com/en-us/library/cc262920%28office.12%29.aspx


Best of luck.
0
 
nsyyoungCommented:
Do you have enough disk space?  

From http://support.microsoft.com/kb/925609:
This problem occurs because there is insufficient disk space.

RESOLUTION
To resolve this problem, perform one of the following actions: Reset the index....To resolve this problem, perform one of the following actions:
•Reset the index.
•Free some disk space. To do this, delete unnecessary content, or add another hard disk.
•Use the Stsadm.exe command-line tool to move the catalog.

See the kb link above for more info.

-n
0
 
altzarAuthor Commented:
there is enough free disk space. more than 50% free per drive minimum.

on the SQL, got 750 G free.

I ran the atsadm -o search -action start,  ( I forgot to do a list before to capture the initial state )
it gave me that the service started successfully, did a LIST after that, it was running on all server.

but on the server that the problem was reported ( SERVER4 ) , the log started to go crazy, same error occurring indefinitely,

0/03/2011 10:25:15.31       mssearch.exe (0x0824)                         0x0708      Search Server                       MS Search Propagation               0      Monitorable      Dumping error record [0]:   Source: Microsoft OLE DB Provider for SQL Server   HRESULT: 0x00040ecd   Code: 0   Description: Input dialect was ignored and command was processed using default dialect.

10/03/2011 10:25:15.31       mssearch.exe (0x0824)                         0x0708      Search Server Common                Exceptions                          0      Monitorable      <Exception><HR>0x80040e14</HR><eip>0139535E</eip><module>d:\office\source\search\ytrip\tripoli\propagation\propdatabase.cxx</module><line>138</line></Exception>

10/03/2011 10:25:15.31       mssearch.exe (0x0824)                         0x0708      Search Server                       MS Search Propagation               0      Monitorable      OLEDB: {? = call dbo.proc_MSS_PropagationQueryServerReportTaskReady(?,?,?,?,?)}, Application: (null), hr error=0x80040e14.


I check and the path on the D: does not exist... and it never did ( since the past 6 month ) .  not sure what to make of it.  I do not have this issue on the other server in the farm and they don't have the path .

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
GeorgeGerguesCommented:
The search Database Log is running out of space

Can you check if the Log has a hard limit on growth set to a specific value ?


You might want to remove this limit for a while.

Best of luck
0
 
altzarAuthor Commented:
if I'm missing some space, is it normal that those logs entry only appear on only 1 of the farm server ?

I have 1 server setup as index

and 3 other setup as query ( it's on 1 of the query that I see those logs entry )

thansk
0
 
GeorgeGerguesCommented:
You will find a Database by the name
[ServerName_DB_Guid]

that would be the search database configured for the server.

check that DB and see if the log file (SQL LOG FILE ) is running out of free space

Steps
SQL manager Connect to SQL Server  >  Databases , - > Right click on your DB and Select Properties
and select the file (Log File ) and select properties ,that should show you if you are set with a limit File limit.

Best of luck
0
 
altzarAuthor Commented:
Sorry for my ignorance... something I think I did not catch...

all my servers are configure in 1 MOSS Farm, so when I look at the database, the server name is not include, it's more the Farm terminology.

so when I talk about the entry in the log, those are locally to server 4 ( inside the locally diagnostic Logging file of the server )

I have hard time relating those entry to one specific database on the SQL Server...

in my logic ( correct me if I'm wrong ), but if limit where reach on the SQL, should I get the same error on each server ? ( locally )

thanks

.. checking all the limits on each database....
0
 
altzarAuthor Commented:
on the database setting, no limits are reach, have more than 50% of disk space free

have 500G total on data volume, only use 220G ( with logs ), logs are set to 2T ( don't ask me why )
0
 
altzarAuthor Commented:
whan I plan to do , shutdown this server, then do a full crawl... see what happen.

other option, remove it from the farm and install a new one.

any other suggestion ?

thanks
0
 
GeorgeGerguesCommented:
I would not remove and add the Server to the farm ( that will cause more problems )

Try Running the Configuration wizard on the server and reboot it .
see if that generates any errors on your Server application log and System log
0
 
altzarAuthor Commented:
those are prod server, would you run the wizard during business hour ?

and I think I found the problem, some patch occure 1 day before the crawl break.
looking into that.
0
 
GeorgeGerguesCommented:
The wizard will cause an IIS RESET on the server where it is running.

be careful
you can do it off hours if you think it is safer.

0
 
altzarAuthor Commented:
I can reboot the server during day hour, I have an external load balancer ( unless the wizard start a iis reset on all the server )

I tought of something else, I could just turn off Searching on server4, then launch a full crawl. until I can point exacly the issue.
0
 
GeorgeGerguesCommented:
It will do IISRESET on that particular server

Reboot / Stop crawl / Recrawl at own risk . this might take a long time.
0
 
altzarAuthor Commented:
here is the conclusion, we are almost positive that the crawl stop working for 1 of the 2 reasons:

- the rules in the VIP was change.
- patch on server 4 was apply incorrectly.

here what solve our issues


1. stop server 4
2. stsadm -o osearch -action stop
3. Restart Office Sp server serach, and wss search in services.msc
4. stsadm -o osearch -action start -role indexquery
5. Assign indexer via "Shared Services Administration", drop-down for SSP>Edit Properties, and complete page, making sure to assign an indexer.
6. Wait for index propagation, 2-5 minutes, and then start full crawl at SSP Admin Page>Search Administration>Content Sources>Start full crawl with content source.
 
0
 
altzarAuthor Commented:
started has a specific problem with a too large possibility source, we open a case with microsoft and found the solution after 1 week of investigation ( trial and error )
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 9
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now