Why does my DNS keep getting reset to 8.8.8.8 ?

I have a small home network with a router and FIOS service.  All the computers on my network keep resetting their DNS server to 8.8.8.8 which I believe is a Google public DNS.

I change the DNS back to 192.168.1.1 and when the reset to 8.8.8.8. happens (often after just 5 minutes) the computers can't find the NAS drives and sometimes each other.

I use static IP addresses for almost all devices on the network.

I also use AVG's Family Safety product which has "whole home filtering" and (I think) send external IP requests to their server so they can decide if my kids can see it or not.  Not sure if this is related to my issue.

Most of the computers are Lenovo and some have their "access connections" software but again, I don't use proxies and have never entered the 8.8.8.8 anywhere myself.

I have checked proxy settings in all the browsers I use (Firefox, IE, and Chrome seems to refer to IE) and it is switched off.

ANyone know how I can switch off this change (or let me know why I shouldn't??)
quentinpAsked:
Who is Participating?
 
Red-KingConnect With a Mentor IT ManagerCommented:
AVG Family Saftey is possibly causing the issue.
From looking over the config doc for it (http://aa-download.avg.com/filedir/doc/OTHERS/Family_Safety/avg_fas_uma_en_2011_02.pdf) it seems that the only DNS setting is to configure your outgoing DNS on your router to use AVG's Failily Safety DNS server.

Is it possible you have something else installed that might set your DNS? It might be worth going through the list in detail.
8.8.8.8 is a public DNS server maintained by Google.

By the way does this happen with all computers or just one of them?
0
 
DrDave242Commented:
You might try setting DNS to 192.168.1.1 on one machine and then searching the registry on that machine for 8.8.8.8.  This will hopefully give you some idea of where it's coming from.  (If you don't change the DNS to the correct value first, 8.8.8.8 will show up in several locations which won't be helpful.)
0
 
Red-KingIT ManagerCommented:
It sounds like you are receiving the DNS settings by DHCP from the router (the router is probably set to give 8.8.8.8 as  the DNS)

Open the properties of your Local Area Connection and look at the properties for "Internet Protocol Version 4" ... where you probably set your static IPs.

Ensure that "Use the following IP address" is selected and the correct IP details are included (probably IP: 192.168.1.2, Subnet Mask: 255.255.255.0, Default Gateway: 192.168.1.1)

If you are using Static IPs on each machine make sure that the "Use the following DNS server addresses" option is selected and set 192.168.1.1 as the preferred server.

Click the Advanced button.
On the "IP settings" tab make sure that everything is correct.

Select the DNS tab and make sure that only 192.168.1.1 is listed in the box at the top.

Hit OK.

Back at the previous window Select the "Alternate Configuration" tab. This should be set to "Automatic private IP address" and generally won't be used if you have a static IP set.

Disable all other network connections you are not using.

With all those setting configured your DNS should not change. Let us know what happens.

Rory
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
quentinpAuthor Commented:
Rory,
Thanks.  I have previously done all of those steps but I don't see an "Alternate Configuration" tab.  

Should have said : I'm on Windows 7
I don't have anything under WINS
I *did* have IPv6 enabled and I just switched this off in case that makes a difference - inspired by your "disable all other connections" comment.
Will wait to see what happens....
Q
0
 
quentinpAuthor Commented:
Just checked and it's back to 8.8.8.8.....
0
 
Red-KingIT ManagerCommented:
2 further options. Firstly, do you have DynDns installed? If so try disabling the service/uninstalling the software.

I also found the following which suggests its an odd setting with Sony Vaio laptops

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/tcp-ipv4-dns-server-address-keeps-changing-to-a/42737057-7a18-47d6-ab2e-682617c9ac5e?page=2

I’ve found the answer. At Least for Sony VAIO under Windows 7. In order to get the TCP/IP V4 settings to stay either at obtain DNS Server automatically or at fixed IP addresses you need to edit the profile. To do this you need to do the following:
1) Start Vaio Control Centre from the all programs menu.
2) Select Network Connections
3) Select Vaio Smart Network.
4) Click on advanced
5) Click on Settings (quickly before the Window disappears)
6) Click on Profile Settings
7) Select the profile you are using
8) Click Edit
9) Select IP and DNS
10) Select Obtain DNS Server Automatically or specify OpenDNS addresses.
11) Click Finsh
and thats it.

Rory
0
 
quentinpAuthor Commented:
Dont have DYnDNS and it's not a VAIO so that control center  isn't there.......
0
 
quentinpAuthor Commented:
Could it be related to Family Safety from AVG?  It seems to use a service from BeSafe....
0
 
quentinpAuthor Commented:
It is all the computers on the network that show this behavior.
If the Router (which I did set up for Family Safety) is the issue - how is telling the computers to change their DNS server?
I changed the Router's DNS server to automatic to see if that will change anything.

"Is it possible you have something else installed that might set your DNS? It might be worth going through the list in detail."

Hmmm....not sure where to look or what to consider.

I do have CISCO Network Magic on most of the computers........

Q
0
 
DrDave242Commented:
Don't think I've ever seen Network Magic, but are the computers without it installed also affected by the issue?  If so, it's not the cause.  Did you ever try that registry search?
0
 
Red-KingIT ManagerCommented:
Yeah, at this point the registry search is definitely worth it. You might at least find what application has that DNS value associated with it.

Another option is to set the dns value to the one that works. Then watch for the change to 8.8.8.8
Note the time that it changes and then have a look in the Event Viewer for any events that might be related to the registry change at that time.
0
 
quentinpAuthor Commented:
I believe it IS Family Safety.  I stopped using Whole Home filtering and the DNS has stayed as I set it.
0
 
Red-KingIT ManagerCommented:
Glad you got it sorted. I'll have to keep that in mind next time I hear about a DNS issue.
0
All Courses

From novice to tech pro — start learning today.