Solved

Linux Network Config Error in Virtual Client on VMware ESXi

Posted on 2011-09-30
3
1,076 Views
Last Modified: 2012-05-12
I am desperately in need of some assistance. I am trying to evaluate running a code stack on a virtual machine and am having difficulty simply getting the Linux operating system installed using a kickstart script. This is urgent at this point, so please help!!

This is a project handed off by someone who struggled through their own evaluation over a month ago and has since moved on to other projects. While she had tried to help, it has been sporadic at best, so I am thinking you might be a better resource.

My current dilemma is that I am trying to utilize a kickstart script during the installation phase of RHEL on the virtual machine I have created on my remote system. The path to the kickstart script (and I have confirmed the location of the script in my browser) I am appending to the end of the default stuff is:

ksdevice=eth0 ks=http://172.16.208.253/ks/rh6.0.ks

The machine is returning an error in utilizing that network connection. Do you any idea why that would be?

Here is the order of the events:

(1) I boot from an ISO on the datastore of the machine.
(2) I hit tab to add the script path to the end of the default "stuff" as indicated above.
(3) The installation states "waiting for networkmanager to configure eth0" for a few minutes
(4) I get the "there was an error configuring your network interface" error

This error only occurs when I am passing the script to the install process. If I do not hit TAB and just allow the installation to run, I have no problems that I know of.

Let me share a personal thought: The woman who was doing this before insists she ran this script as part of the installation process – and that she pointed to the network location to do so. Perhaps I am out of my expertise here, but how can an OS that has not yet been installed on a VM possibly know anything about the network when it has not yet been configured.

Another solution to this issue might (keyword: might) be to locate the kickstart script locally inside the datastore, but I have been unsuccessful in my attempts to point the install process (which is being kicked off from an ISO on the datastore) to the same directory where the ISO is located. Can someone possibly direct me on that one? What would I pass?? I have tried the following:

ks=/rh.6.ks
ks=/quick-deploy/rh.6.ks

Does the "ksdevice=" part have to be here (reference line above for format) and, if so, what would it look like??

A simple troubleshooting note: I can ping the box running the ESXi server, so I know the physical NIC is working there. This is definitely a network configuration issue during the Linux installation on the virtual machine.

A timely response will be awarded 500 points. I am up a creek here and my project cannot move forward without your assistance. Help me, Obi Guru Kenobi... You're my only hope. :(
0
Comment
Question by:SaucyJim
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 3

Accepted Solution

by:
mkrohn earned 500 total points
ID: 36893093
It looks like your virtual machine is configured to setup networking via DHCP.
You have two choices:
1) Check that the vmware server in the host machine has DHCP server enabled,
2) or Setup the network in your virtual machine to use a static IP Address. You can do it by editing /etc/sysconfig/network-scripts/ifup-eth0

Hope this helps
martin
0
 

Author Comment

by:SaucyJim
ID: 36893363
Hi Martin...

Thanks for the timely response. I should qualify myself as a newbie in the WMware arena, so I'd appreciate pointers on these possible solutions:

(1) Enabling the DHCP server on the host machine: I have poked around the edges of the host using the vSphere client, but do not see any place where I can flip a switch to enable this. Can you briefly describe that process?

(2) Editing the /etc/sysconfig/network-scripts/ifup-eth0 file on the virtual machine: If the OS has not yet been installed on the machine, this file will not yet exist right? Remember that I am trying to pass an established kickstart to the installation process.

Keep me posted... I'll be searching for the DHCP stuff in the meantime.

Thanks!

James
0
 

Author Comment

by:SaucyJim
ID: 36894421
I have no additional information here. I think my primary issue has become the configuration/setup of the network adapter inside the virtual machine. If I have no responses to help with this by the end of the day, I will close this issue as unanswered. Sorry... But I need help NOW.

:(
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Create your first Windows Virtual Machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, the Windows OS we will install is Windows Server 2016.
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Teach the user how to install and configure the vCenter Orchestrator virtual appliance Open vSphere Web Client: Deploy vCenter Orchestrator virtual appliance OVA file: Verify vCenter Orchestrator virtual appliance boots successfully: Connect to the …
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question