Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

rpm will not upgrade python

Posted on 2011-09-30
5
Medium Priority
?
982 Views
Last Modified: 2012-05-12
Hi,
   I need to install python-devel-2.4.3-44.el5_7.1.i386.rpm on a CentOS 5.5 system.

When I try with the Package Manager i get: "pkgKey 4537 doesn't exist in repo base"

Not finding out what this means thru Google, I thought I would just find the RPM and do it manually.

when I tried rpm -i python-devel-2.4.3-44.el5_7.1.i386.rpm I get...
    error: Failed dependencies:
        python = 2.4.3-44.el5_7.1 is needed by python-devel-2.4.3-44.el5_7.1.i386
        python < 2.4.3-44.el5_7.1 conflicts with python-devel-2.4.3-44.el5_7.1.i386

SO I tried rpm -i python-2.4.3-44.el5_7.1.i386.rpm   and i get...
    error: Failed dependencies:
        python-libs-i386 = 2.4.3-44.el5_7.1 is needed by python-2.4.3-44.el5_7.1.i386


SO I tried  rpm -i python-libs-2.4.3-44.el5_7.1.i386.rpm and I get...
    error: Failed dependencies:
        python < 2.4.3-32.el5 conflicts with python-libs-2.4.3-44.el5_7.1.i386

See how I am in a closed loop here. Libs wont install becasue basic python is wrong , and when I try basic python it says it needs libs.

It seems that the old 2.4.3-27 (on the system now) had basic and libs combined, Now that its two separate packages, it does not know what to do.

I even tried rpm -U python-2.4.3-44.el5_7.1.i386.rpm, and I got
    error: Failed dependencies:
        libpython2.4.so.1.0 is needed by python-2.4.3-44.el5_7.1.i386
        python-libs-i386 = 2.4.3-44.el5_7.1 is needed by python-2.4.3-44.el5_7.1.i386
        libpython2.4.so.1.0 is needed by (installed) gnome-python2-gnomevfs-2.16.0-1.fc6.i386
        libpython2.4.so.1.0 is needed by (installed) rhythmbox-0.9.5-8.el5.i386
        libpython2.4.so.1.0 is needed by (installed) libsemanage-1.9.1-4.4.el5.i386
        /usr/lib/python2.4 is needed by (installed) libxml2-python-2.6.26-2.1.2.1.i386
        /usr/lib/python2.4 is needed by (installed) gamin-python-0.1.7-8.el5.i386


PLEASE DO NOT tell me I need to remove ALL these applications that require python before I can upgrade it.

                       Thanks,
                       Steve


0
Comment
Question by:slats52
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 21

Expert Comment

by:Papertrip
ID: 36893204
Is that the version that is in your yum repositories?  If not, is there a reason you need that specific version?

One of the greatest things about yum is that it manages all dependencies for you, so that you don't run into this exact issue.
0
 

Author Comment

by:slats52
ID: 36893220
Thanks for the quick response papertrip, but I think thats my problem. I believe that yum is whats running behind the Package Manager GIU.

When I try to let the package manager do the job i get the error I mentioned above.

                       "pkgKey 4537 doesn't exist in repo base"

When I tell it to install the python-devel package. (yes, the one i the repository)

              Steve

0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36893241
Alright let's do this using yum on the command line so we can get some more verbose errors.

First let's clean the slate
yum clean all

Open in new window

Then
yum install python-devel

Open in new window


IF that still throws an error, then 'yum clean all' again, then
yum info python-devel

Open in new window

and paste it here.

Sure we could go the route of downloading and installing all the dependencies, but via yum is definitely the right way to go, if we can get it working of course.
0
 
LVL 21

Accepted Solution

by:
Papertrip earned 2000 total points
ID: 36893244
Oh and paste the complete errors you get from any of those commands... don't need all the fluff just the good stuff.
0
 

Author Closing Comment

by:slats52
ID: 36893368
Well papertrip, you definitely deserve that rank of 'Guru". Going thru the command line steps that you outlined seems to have gotten rid if that funny error I was getting.

The whole process went off without a hitch and even upgraded a few other packages in the process.

Problem Solved!!!!

                  Many Thanks for your help!

                          Steve
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question