• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2730
  • Last Modified:

Outlook 2010 Plus "The Server is Unavailable" error with RDweb

I just deployed Office365 to an existing Outlook 2010 Plus environment, everything runs perfect using RDP however we have been using RDweb for all of our desktops and as soon as I try to launch Outlook 2010 in RDweb i get the error "The server is unavailable", close RDweb and connect with RDP and it runs perfectly.

The RDweb server is 8R2 with all updates and patches installed as well as Office 2010 Plus.

Any ideas on what might be going on?

Thanks,

Dave
0
dw6392
Asked:
dw6392
1 Solution
 
Jaroslav MrazCTOCommented:
OTher applications is runing ok? In console you have two configs one is for RDP and another is for RDWeb you must set certifiacte and profiles. Go also to remoteapp menu and check also RemoteApp manager.
0
 
dw6392Author Commented:
Yes all other apps in RDweb are running fine, Outlook was also running fine (with POP3) until I added the exchange (Office365) account to the Outlook profile.  RDweb has been up and running great for about 9 months now, yesterday I added the Office 365 (exchange) account and that was when it failed.  If I connect to the server with RDP outlook runs fine so I know it is not a setting in Outlook.
0
 
Jaroslav MrazCTOCommented:
Stupid question but did you reboot server? Did you try to remove outlook profile in mail settings of control panel and try to do it again? Some times are problems with security.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell┬« is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
dw6392Author Commented:
Yes, I rebooted the server and removed and reinstalled the 365 account ... I did however do this from the console ... I will remove the 365 account again now and then try to add it through RDweb.  Another possible problem could be with Lync, does outlook launch Lync or do anything with it that maybe RDweb does not like?
0
 
Jaroslav MrazCTOCommented:
Hmm its including all plugins. When its starts it initalize all plugins you can see them in addon section of settings. Try to remove but not just Office360 also delet Outlook profile, becouse youst acconunt dont helps
0
 
dw6392Author Commented:
So  here is what I tried,

Delete the account
logged in to RDweb and then Outlook -> everything is good
added the exchange account -> showed account added successfully
relaunched Outlook in RDweb and got the error can not connect to server with a screen to verify the exchange server settings
hit ok and it gave a server connection error and then opened outlook with only the POP3 accounts
tried to add it again -> same results
logged out of RDweb and opened Outloock in RDP, added the account and everything works fine in RDP
logged out of RDP and logged into RDweb -> same error as first time "The server is unavaiaible"

Could there be another security setting in RDweb for exchange that I do not have enable, almost seems to me that RDweb is blocking ports or something which prevents Outlook from connecting to Exchange.
0
 
Jaroslav MrazCTOCommented:
Hmm i have one idea RDweb is using user account to be able to see it. Is IIS user able to use plugin? Do you have some special plugn for office360 or just regulary exchange? Yes and user certificate is trusted on server?
0
 
dw6392Author Commented:
There is no special plugin for 365, it is just a hosted cloud exchange server.

I do not know how to to see if an IIS user can use a plug-in in RDweb.

pardon my ignorance but how do I verify user certificate on the server ... I want to say yes but I would like to verify it.

Thanks for your help so far,

Dave
0
 
Jaroslav MrazCTOCommented:
Werifiy is simple go on OWA of Office 360 by IE. And see if page is encrypted wit ssl. If IE when you go on ssl (HTTPS) dont promt you that is not trusted page its ok. If it promts you there will be sign of red shild with white cross near adress. You must click there see more information abou certificate. THen go on second tab and click copy to file. Save certificate on desktop double click on it and instal it to trusted root certification autorities.
0
 
dw6392Author Commented:
I think we have a misunderstanding, 365 on IE is on HTTPS and it not a trusted page, this however is not the problem and the web aps work fine on RDweb.  I do not want to use the web apps locally, I want to use the office 2010 Pro suite which I already had and have it connect to the 365 "exchange" server, which it does fine locally, or RDP, it just will not work through RDweb, this is the problem I am having.  I think it is a security setting in RDweb or an RDweb policy somewhere that is preventing it from connecting to the "exchange" server on 365, The exact same program works fine on RDweb which usins the same credentials as RDP as far as the desktop applications go.

Something in RDweb is preventing Outlook 2010 plus from connecting to the "exchange" server on the cloud based 365.  I actually have no intention of using the web apps of 365 unless I am out of town and my PDA does not work or I need to use an office document quickly while travelling.
0
 
dw6392Author Commented:
I retried everything again over the weekend and still have the same problem and the problem is ONLY there when uning RDweb, Outlook is running perfect in RDP but can not connect to server in RDweb.
0
 
Jaroslav MrazCTOCommented:
Try also microsoft support for 360. Iam thinking but no idea now.
0
 
dw6392Author Commented:
I am still working on this ... still no luck on my end yet.
0
 
dw6392Author Commented:
Today I figured this out, it was what I suspected in my post from Oct 1st.

RDweb is blocking the Outlook Pop-up windows for the login credentials, I entered my crededtials and told it to remember me in RDP and then launched the program again in RDweb and VOILA ... Everything is working great now.

PS, I had tried Microsoft before and they were now much help at all as they were sending me back info that had nothing to do with my problem.
0
 
dw6392Author Commented:
I am actually surprised in general with the lack of knowledge of RDweb.  Not just here but on every forum that I have been on.  I find it far superior to TS and easier to maintain and control access.

So in summary, the lack of knowledge of RDwen and the fact that Office365 is fairly new as well, I guess I am not overly suprised that no solution from Experts Exchange was given.  

Since no solution was given and I felt like I was providing more input to the conversation I do not feel like I was helped on this question at all ... I actually felt more like I was explaining how the system works instead of what is not working.

On a up note ... most responses were prompt on your end, however none provided usefull information for my problem.
0
 
bmwe46Commented:
Sorry to open an old thread, but I have another question around your solution.  We too just implemented Office 365 and ran into the same problem (which brought me here).  My question is, how do you get around this thru RDweb, since the passwords expire every X days?  Or do you RDP into the server for every user, each time the passwords change to update?  Thanks!
0
 
AHSBCommented:
There is a solution for this problem.

Make sure you have installed update: kb2596996
(Office 2010 SP1 and all updates from Windows Update applied already has this KB)

After you install the hotfix package, follow these steps to enable the hotfix:
1.Click Start, click Run, type regedit in the Open box, and then click OK.
2.Locate and then select the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\General
3.On the Edit menu, point to New, and then click DWORD (32-bit) value.
4.Type DoNotQueryUserNotificationState, and then press ENTER.
5.Right-click DoNotQueryUserNotificationState, and then click Modify.
6.In the Value data box, type 1, and then click OK.
7.Exit Registry Editor.

Also see: http://support.microsoft.com/kb/2596960/en-us

Tested this today and it works. Now when a user starts Outlook using RDWeb or a RDS file, the windows security windows comes up in the TS. Selecting the option "remember the password" will prevent the security window to popup again (at least until the next password change).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now