Solved

Cisco 800 - Route Between 2 Networks

Posted on 2011-09-30
13
507 Views
Last Modified: 2012-06-27
Greetings,

My Cisco knowledge is a little rusty..... could use a hand. :-)

I have 2 networks connected in the same building - 192.168.21.0/24 (main ntwk) and 192.168.250.0 (secondary ntwk). The Cisco 800 is sitting in the 192.168.21.0 network,  interfaces are WAN-GE 192.168.21.20, VLAN1 192.168.250.1.

From inside the 192.168.250.0, I can get anywhere in the 192.168.21.0 network.
I'd like to allow all traffic from 192.168.21.0 to get to everywhere in 192.168.250.0.

What's the best way to accomplish this? Again, my apologies... my Cisco is rusty! :-)

Thanks,

E.D.
0
Comment
Question by:edalzell
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 2
13 Comments
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 250 total points
ID: 36895205
If devices on the 250.0 network can get to the 21.0 network, then the 21.0 network can get to the 250.0 network.

Unless there's NAT or an ACL or something else going on.

Would need to see the config of the router to know for sure.
0
 

Author Comment

by:edalzell
ID: 36895355
Here's the config... thanks! :-)

firoute1#sho configuration
Using 4416 out of 262136 bytes
!
! Last configuration change at 20:39:01 PCTime Fri Sep 30 2011 by cisco
! NVRAM config last updated at 20:39:08 PCTime Fri Sep 30 2011 by cisco
!
version 15.0
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname firoute1
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200
logging console critical
enable secret 5 $1$e3bL$frr.2meHryxyUvWK3KviV/
!
no aaa new-model
!
!
!
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
!
crypto pki trustpoint TP-self-signed-2230413360
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2230413360
 revocation-check none
 rsakeypair TP-self-signed-2230413360
!
!
crypto pki certificate chain TP-self-signed-2230413360
 certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
no ip source-route
!
!
ip dhcp excluded-address 192.168.250.1 192.168.250.4
ip dhcp excluded-address 192.168.250.11 192.168.250.254
!
ip dhcp pool ccp-pool1
   import all
   network 192.168.250.0 255.255.255.0
   default-router 192.168.250.1
!
!
ip cef
no ip bootp server
no ip domain lookup
ip domain name kawarthacu.com
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO891-K9 sn FGL1536217Q
!
!
username admin privilege 15 secret 5 $1$..DJ$eY7FB0k.qtppPW9FkwWNC.
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
!
!
!
!
interface FastEthernet0
 !
!
interface FastEthernet1
 !
!
interface FastEthernet2
 !
!
interface FastEthernet3
 !
!
interface FastEthernet4
 !
!
interface FastEthernet5
 !
!
interface FastEthernet6
 !
!
interface FastEthernet7
 !
!
interface FastEthernet8
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0
 description $ES_WAN$$FW_OUTSIDE$
 ip address 192.168.21.20 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$$ES_LAN$$FW_INSIDE$
 ip address 192.168.250.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 !
!
interface Async1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation slip
 !
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 1 interface GigabitEthernet0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.250.0 0.0.0.255
no cdp run

!
!
!
!
!
!
control-plane
 !
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

^C
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 transport output telnet
line 1
 modem InOut
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end
0
 
LVL 2

Accepted Solution

by:
simplejack earned 250 total points
ID: 36896044
Disable nat and you shoud be good to go.
0
Defend Your Organization from The Greatest Threats

Looking to fill the gaps in your security? Bring together information from the network, endpoint and threat intelligence feeds to really see what's happening in your organization. Join the WatchGuardians in their adventures fighting cyber crime!

 
LVL 50

Expert Comment

by:Don Johnston
ID: 36896291
You've got nat configured for the 250 to 21 traffic. Either disable it, or enable inbound translations.
0
 

Author Comment

by:edalzell
ID: 36896356
Great, thanks for the tfeedback.

One more thing... what if I JUST want 192.168.20.15 to have access?

Thanks again!
0
 
LVL 2

Expert Comment

by:simplejack
ID: 36896359
Access to what?
0
 

Author Comment

by:edalzell
ID: 36896373
Sorry... if I just wanted 192.168.21.15 to have access to 192.168.250.0?

Rather than the entire subnet having access to 192.168.250.0, as a security measure, just one IP, e.g. 192.168.21.15.

(Sorry, type-o on IP address in prior msg)

Thanks,

E.D.
0
 
LVL 2

Expert Comment

by:simplejack
ID: 36896432
So to make it clearly - you want to allow some host, which is behind outside interface to be able to interact with hosts in your lan subnet without letting nat go? Either VPN or NAT Virtual Interface.

Check this article out http://blog.ine.com/2008/02/15/the-inside-and-outside-of-nat/
0
 

Author Comment

by:edalzell
ID: 36897414
Ok... still having a bit of a problem.
Trying first to allow ALL outside traffic - if I disable NAT, I still cannot ping from 192.168.21.5 --> 192.168.250.5. Am I missing something?

BTW, I am using the CCP software, not the CLI.

Thanks! :-)
0
 
LVL 2

Expert Comment

by:simplejack
ID: 36897517
Show your latest configuration.
0
 

Author Comment

by:edalzell
ID: 36901152
Sorry for the delay


firoute1#sho configuration
Using 4416 out of 262136 bytes
!
! Last configuration change at 20:39:01 PCTime Fri Sep 30 2011 by cisco
! NVRAM config last updated at 20:39:08 PCTime Fri Sep 30 2011 by cisco
!
version 15.0
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname firoute1
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200
logging console critical
enable secret 5 $1$e3bL$frr.2meHryxyUvWK3KviV/
!
no aaa new-model
!
!
!
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
!
crypto pki trustpoint TP-self-signed-2230413360
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2230413360
 revocation-check none
 rsakeypair TP-self-signed-2230413360
!
!
crypto pki certificate chain TP-self-signed-2230413360
 certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
no ip source-route
!
!
ip dhcp excluded-address 192.168.250.1 192.168.250.4
ip dhcp excluded-address 192.168.250.11 192.168.250.254
!
ip dhcp pool ccp-pool1
   import all
   network 192.168.250.0 255.255.255.0
   default-router 192.168.250.1
!
!
ip cef
no ip bootp server
no ip domain lookup
ip domain name domain.com
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO891-K9 sn FGL1536217Q
!
!
username admin privilege 15 secret 5 $1$..DJ$eY7FB0k.qtppPW9FkwWNC.
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
!
!
!
!
interface FastEthernet0
 !
!
interface FastEthernet1
 !
!
interface FastEthernet2
 !
!
interface FastEthernet3
 !
!
interface FastEthernet4
 !
!
interface FastEthernet5
 !
!
interface FastEthernet6
 !
!
interface FastEthernet7
 !
!
interface FastEthernet8
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0
 description $ES_WAN$$FW_OUTSIDE$
 ip address 192.168.21.20 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip virtual-reassembly
 duplex auto
 speed auto
 !
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$$ES_LAN$$FW_INSIDE$
 ip address 192.168.250.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 !
!
interface Async1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation slip
 !
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.250.0 0.0.0.255
no cdp run

!
!
!
!
!
!
control-plane
 !
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

^C
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 transport output telnet
line 1
 modem InOut
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

0
 
LVL 2

Expert Comment

by:simplejack
ID: 36901742
try to remove

 no ip redirects
 no ip unreachables
 no ip proxy-arp

Open in new window


from gi0 and vlan1 interfaces.
0
 

Author Comment

by:edalzell
ID: 36909463
Got it working... ughhh.

ip route A.B.C.D 255.255.255.0 nethop IP.

I was using the outgoing interface, rather than the next hop IP.

Thanks all!
0

Featured Post

Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco ASA 5512 LAN Config 16 128
snmp-server enable traps gdoi ks-rekey-pushed 3 37
VLAN Question 7 48
Home firewall recommendations 11 105
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question