Solved

(Sharepoint 2010 Central Admin) Internet Explorer cannot display the webpage

Posted on 2011-09-30
10
1,791 Views
Last Modified: 2012-05-12
Hi Guys,
I installed SP 2010 on Windows 7.
I am able to succesfully create "SP_Config" and "Sharepoint_AdminContent" databases.
Now, when I open the central admin, I get the error "Internet Explorer cannot display the webpage"

I also tried to open "http://localhost"
This gives me the error"
Could not load type 'System.ServiceModel.Activation.HttpModule' from assembly 'System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

Your help is appreciated...!!
0
Comment
Question by:me24hour
  • 5
  • 5
10 Comments
 
LVL 6

Expert Comment

by:penguinjas
ID: 36898466
To resolve this problem, you must use the ASP.NET IIS Registration Tool (Aspnet_regiis.exe,) to register the correct version of ASP.NET. This can be accomplished by using the –iru parameters when running aspnet_regiis.exe as follows:

aspnet_regiis.exe -iru

http://social.msdn.microsoft.com/Forums/pl-PL/wcf/thread/39571e42-aca7-469d-8c68-aa59c2da4fcc
0
 

Author Comment

by:me24hour
ID: 36898477
thanks, but when i try to run the command aspnet_regiis.exe -iru , I get an error that it is unrecognized.
I am using command prompt to do that.

Can you please tell me the steps involved in registering correct version of Asp.net.
0
 
LVL 6

Expert Comment

by:penguinjas
ID: 36898492
So browse to the correct folder for the .net version you are running then run then command.

Example: open command prompt then enter cd %SystemRoot%\Microsoft.NET\Framework\v4.0.30319

NOTE: When running aspnet_regiis.exe, you must ensure that you run the version supplied with the .NET Framework version that you want to use. The .NET Framework 4 version of aspnet_regIIS.exe is located in the following path(s):

32-bit systems: %SystemRoot%\Microsoft.NET\Framework\v4.0.30319
64-bit systems: %SystemRoot%\Microsoft.NET\Framework64\v4.0.30319
0
 

Author Comment

by:me24hour
ID: 36898509
Okay, asp.net is now registered succesfully.
i am now able to open "http://localhost
But, when I try to open central admin, I get an same error "Internet Explorer cannot display the webpage"
0
 
LVL 6

Expert Comment

by:penguinjas
ID: 36898511
Does anything stand out in your application logs?  Any errors?  Make sure you have the sharepoint services running.  Did you select a specific port to install under?  Like http://localhost:9000 or something?
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:me24hour
ID: 36898528
the port i am using is 14207
I don't see any errors in logs under 14 hive.
Can you please tell how to check whether sharepoint services is running or not.
thanks for your patience with me
0
 
LVL 6

Expert Comment

by:penguinjas
ID: 36898546
So to access the admin page you need to enter http://localhost:14207
Did you try that?
0
 

Author Comment

by:me24hour
ID: 36899893
Yes, I tried it but still the same error "Internet Explorer cannot display the webpage"
I also want to mention that I am installing it on Windows 7.
I used the setup wizard but to create the sharepoint_config and admin_content databases, I uses the powershell. (I didn't install it using the wizard).
0
 
LVL 6

Accepted Solution

by:
penguinjas earned 500 total points
ID: 36903939
There are soo many steps to installing and configuring Sharepoint anything you may have missed could cause this issue. Please review this step-by-step guide on installing Sharepoint 2010 on Windows 7 and see if there is some pre-requisite you may have missed.

http://msdn.microsoft.com/en-us/library/ee554869.aspx
0
 

Author Comment

by:me24hour
ID: 36915226
It finally worked.
Here is the issue I was facing.
I ran the Configuration Wizard half-way. I created Shrepoint_config and admin_content databases using Powershell.
But, after that I didn't run rest of the configuration wizard and I was directly trying to open the Central admin.

Thanks for your help...appreciate it.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

As with any other System Center product, the installation for the Authoring Tool can be quite a pain sometimes. This article serves to help you avoid making these mistakes and hopefully save you a ton of time on troubleshooting :)  Step 1: Make sur…
Lync meeting or Lync conferencing is what many organizations would like to deploy to allow them save money. But companies are now giving up for various reasons, one of which is that they cannot join external meetings (non-federated company meetings)…
Viewers will learn how to maximize accessibility options in an Excel workbook for users with accessibility issues.
This is Part 3 in a 3-part series on Experts Exchange to discuss error handling in VBA code written for Excel. Part 1 of this series discussed basic error handling code using VBA. http://www.experts-exchange.com/videos/1478/Excel-Error-Handlin…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now