Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Cannot access application under IIS from another PC

Posted on 2011-10-01
4
Medium Priority
?
445 Views
Last Modified: 2012-05-12
Hi everyone,

I have a little "problem" with one of my IIS-website. I have made a new website under IIS with an application under it. The application is the spam-quarantaine management from GFI mailessentials.

It works this way: Every hour, the users are send a report of the spam quarantaining. They receive a link on which they have to click and then they are guided to the IIS-website. The problem is that when I click on this link on the server running the IIS-website, everything works great. But when I go to this website using another PC, it just doesn't work.

I have set the following binding:
Type: HTTP
IP-address: All Unassigned
Port: 20000
host name: server (same name as the server is called)

It works from the server, but not from the other clients. What do I have to do to give other computers access? I am new to IIS and don't know my way around it that good..

Thanks in advance!
0
Comment
Question by:Silencer001
4 Comments
 
LVL 15

Expert Comment

by:Eyal
ID: 36895790
can you ping the server from the other computers? netnet on port 80 is working?

ipconfig /flaushdns?
0
 
LVL 5

Expert Comment

by:Plk_In_EE
ID: 36895955
Hi there,
please refer the below blog where you will get some answer

http://brian-dao.blogspot.com/2007/05/access-iis-application-from-computers.html

Good luck.

karuppan
0
 
LVL 18

Accepted Solution

by:
Andrej Pirman earned 500 total points
ID: 36896106
- another setting on IIS bindings could be to change from "All unassigned" to specific IP
- then check, if there is no FIREWALL inbetween. Is this 2008 server? You must allow TCP port 20000 in on firewall, for all scopes.
- how does link look like? is it http://servername:20000/something or http://192.168.0.10:20000/something ? Check host-headers value in IIS if accessing by servername - host-header should match your server name in the link and in the IIS binding properties.
0
 

Author Closing Comment

by:Silencer001
ID: 36898093
Thanks Labsy, it was indeed the firewall port that needed to be opened. Should have tried this first, thanks for the solution!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I work for a company that primarily works with small businesses as their outsourced IT vendor. As such the majority of these customers utilize some version of Small Business Server. Due to the economics of running a small business, many of these cus…
If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
Screencast - Getting to Know the Pipeline
Suggested Courses

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question