How do I restore the public folders in Exchange 2003?

I then tried restoring just the Public Folder Store from the previous night’s backup but I can’t get it to mount.  

I tried restoring the Public Folder Store:

 (See screenshots 1 -3 below)

Restore Status
Operation: Restore

Backup of " XXXXCORPEMAIL04\Microsoft Information Store\First Storage Group", Restored to"XXXXCORPEMAIL04\Microsoft Information Store\First Storage Group"
Backup set #1 on media #1
Backup description: "Set created Thursday"

Restore started on 9/30/2011 at 11:16 PM.
Restore completed on 9/30/2011 at 11:59 PM.
Directories: 3
Files: 11
Bytes: 10,546,074,836
Time:  43 minutes and  4 seconds


But, when I try to mount the database, I get:

 (see screenshot 4 below)

What am I doing wrong????

 screenshot screenshot3.jpg
Who is Participating?
MorasivaConnect With a Mentor Commented:
Run the HARD REPAIR by using the the command ESEUTIL /P "path of the database"
grhelmAuthor Commented:
BTW, this is teh command that is used to crteate the backups:

C:\WINDOWS\system32\ntbackup.exe backup "@C:\Backup\exchbu.bks" /n "ExchangeBackupThur.bkf" /d "Set created Thursday" /v:yes /r:no /rs:no /hc:off /m normal /j "exchbu" /l:s /f "R:\Backup\HTS\xxxxcorpemail\ExchangeBackupThur.bkf"
The ID no: C1041724 indicates that  there is insufficient free disk space on the drive that contains the databases that you are trying to mount. .

Check the Free Disk Space on the server.

Reference article
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

grhelmAuthor Commented:
I'll check the freespace, but just looking at it initially there is at least 7GB of space available.

One other thing I wanted to note, I did try eseutil:

grhelmAuthor Commented:
Some additional info:

Free space is 9.54 GB

And the event viewer shows:
grhelmAuthor Commented:
Following the instructions at did not work.

I moved all the log files from

D:\Program Files\Exchsrvr\MDBDATA

to a temp directory and then copied all the log files from:

C:\temprest\First Storage Group
(The location that was refrenced during the RESTORE and the logfile range referenced by the eseutil /cm command.)

I then tried remounting the Public Folder DB in ESM and I get the same C1041724 error.
grhelmAuthor Commented:
Okay, running the hard repair...
grhelmAuthor Commented:
That seems to have worked, thanks!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.