Windows 7 Screensaver

Hey experts, does anyone know how to create a shortcut to start the screensave in windows 7. I already have a shortcut to the SCR screensave and it does not meet my purpose. What I want is a way to start the screensaver where the on resume ask for the user password. The shortcut to the SCR screensaver file does NOT prompt for a password once the system resumes. So, any ideas?
stevensontAsked:
Who is Participating?
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Hi stevensont, you can start you favorite screensaver by adding /s to the commandline, like this:

%windir%\system32\scrnsave.scr /s

Open in new window

where the .scr is the screensaver you like.

You can configure the screensaver to lock automatically in the control panel but starting it with the method above will not lock it.

To lock as well, do this:
%windir%\system32\scrnsave.scr /s & rundll32 user32.dll,LockWorkStation

Open in new window


In a shortcut, add 'cmd /c', like this:
cmd /c %windir%\system32\scrnsave.scr /s & rundll32 user32.dll,LockWorkStation

Open in new window

0
 
Em ManCommented:
Did you try adding your *.scr to the screensaver default folder? so that you can change the settings to put a password when it resume?

What Flavor of Windows 7 do you have?
0
 
stevensontAuthor Commented:
C:\Windows\System32\*.scr are the default screensaver for windows 7 64-bit.

I forgot to mention in my first post that when the screensaver automatically execute from the wait time, on resume, the password is enabled. It only doesn't work for the desktop shortcut.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
khairilCommented:
Hi,
Calling the *.scr directly (from shortcut) won't activate lock on workstation as it not trigger calling to lock workstation (I assume power profile is doing this calling)

However, you still can call *.scr and lock workstation after that, http://cinderwick.ca/blog/2011/04/activate-screensaver-lock-desktop-shortcut-windows-xp/

It is not the good solution but you can try it first.
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
@khairil - I'm sorry, I think you are repeating what said already, your link points to the exact solution to what I'm posting and I also mentioned that it won't lock by just calling the .scr. Please read previous posts :)
0
 
stevensontAuthor Commented:
It works for me. Thanks, been trying to figure this out for a while.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.