Reinstalling Exchange 2003 / Windows 2003 hang with "applying computer settings"

I'm running Exchange 2003 in Windows 2003, virtual on vsphere 4. Storage is on NAS with NFS. The NAS was inaccessable for half an hour while the server was running, so the VM crashed.
The Exchange server was also DC.
After the NAS was up again, the VM could not start because the AD was corrupt. So my plan was to take the AD role of (dcpromo with force option) and reinstall Exchange (see http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_21621203.html), in order to get a Exchange server without the AD role. I wanted to get rid of it for some time, wanted to install a second Exchange without AD and move mailboxes, but now , because AD was broken, I choose this path.

I deinstalled AD succesfully, after that the server was out of the domain. I made it a domain member again and reinstall Exchange, but now the server hangs with "Applying computer settings" for more than an hour. With hang, I mean not really hanging, the dialog box is responsive, I can ping the server, but I cannot do anything while it is in this state.

I powerd it off, booted in safe mode with network an checked DNS settings. DNS settings were 2 other DNS servers, up and running. I changes one of the DNS settings to 127.0.0.1 and resatrted normally, but it is still "hanging" now.

Any idea's what can be wrong?
RBraatAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RBraatAuthor Commented:
addition:
Because the server was out of the domain and I had to put it in again, I renamed the server because the old name alreaddy existed in AD. I did not remove the old name, but choose to rename the server.
I clean up the AD (because the DC role has gone) afterwards
RBraatAuthor Commented:
addition:
I was able to check the Exchange servers event logs from another computer. I see a lot of errors, most of them about exchange services having not the right permissions. Thas must be because of the denotion of the AD. Should be able to fix it after reinstalling Exchange.
I see nothing about policies being applied or errors about it.

I also started a second terminal session to the server and tried to log in with the local admin account (on the console I logged in with the domain admin accout). This sessions is also stuck with "Applying computer settings"...

Still stuck.
Renato Montenegro RusticiIT SpecialistCommented:
Just a few things to check.

Make sure you have moved all the FSMO roles to the surviving domain controller. You can check them out by issuing this command at your DC:

netdom query fsmo (if it's a 2003 box, you need Windows 2003 Support Tools)

Using Ntdsutil.exe to transfer or seize FSMO roles to a domain controller
http://support.microsoft.com/kb/255504

If the FSMO are ok, make sure the exchange box computer's account is valid. Check the system log by remote managing the server. If it's not, make sure the computer's clock is in sync with the domain controller and try to reset the computer account or rejoin.

Sometimes a windows machine can take longer to start because the Service Control Manager is stuck at some point. Remote manage the server and open its services pane. Look if there is some service stuck in the Starting state.

Well, check those things and get back here.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

RBraatAuthor Commented:
All 5 FSMO roles are on another DC, I did this some time ago because I was already planning to denote this DC in the future. Checked it with netdom quert fsmo to be sure.

The exchange's computer account has to be ok, because after the denotion I've put it again in the domain. It exists in AD in the COMPUTERS's OU.
I can connect to the system log of the Exchange server from another server, so I think this also indicates the account is OK.
I see some loggings application log from MSExchangeSA, repeating every minute with the correct time, so the Exchange's time miust also be OK. The repeating error is from MSExchangeAccess, sayin "Process INETINFO.EXE (PID=1888). Topology Discovery failed, error 0x80040a02.", followed by a warning from MSExchange SA saying "Microsoft Exchange System Attendant does not have sufficient rights to read Exchange configuration objects in Active Directory. Wait for replication to complete and then check to make sure the computer account is a member of the "Exchange Domain Servers" security group." Because it was not I added it to it.

In the meantime, just 2 minutes ago, the "Applying computer settings" dissapeared and I was able to log in. The message box must have been there for about 3 hours ...

I'm nog goint to reinstall Exchange ....
Renato Montenegro RusticiIT SpecialistCommented:
Make sure you can access the domain controller from the Exchange box. You can also rerun the Exchange DomainPrep to recreate the security configuration for Exchange:

How to Run Exchange Server 2003 DomainPrep
http://technet.microsoft.com/en-us/library/aa997526(EXCHG.65).aspx
Renato Montenegro RusticiIT SpecialistCommented:
Also, check your Global Catalog. You must have one in the same site.
RBraatAuthor Commented:
I can access tge other DC. I am also logging in now with DOMAIN ADMIN. The other DC is GC.
I've run the DomainPrep without problems.
After that I ran setup again to do the reinstall. In the COMPONENT SELECTION screen I am able to select REINSTALL. So far so good. But when I click NEXT it says me "Select a Server in an Exchange 5.5. Organization". Huh? I don't have one! But in order to continu, I have to specify a name. Of course, nothing is valid.

I am following this procudure: http://technet.microsoft.com/en-us/library/aa997239%28EXCHG.65%29.aspx
After step 3 (my screen is identical) I should go to step 4.
According to step 4 i should see the "The Installation Summary page", but I get the "Select a Server in an Exchange 5.5. Organization" dialog ...

Stuck again ...
Renato Montenegro RusticiIT SpecialistCommented:
Renato Montenegro RusticiIT SpecialistCommented:
Or try searching EE. I cannot see the EE docs right now because Im under a limited account (i was away from EE for some months).
RBraatAuthor Commented:
I don't have a recent backup (few days old) so I'm eager to do a reinstall so my data stays recent.
This article http://forums.msexchange.org/m_1800416029/mpage_1/key_/tm.htm#1800416236 says there should be a leftover whick I should delete, but I'm having trouble to find this ...
RBraatAuthor Commented:
I've looked with ADSIedit at my domain's NAMING CONTENT "CONFIGURATION". I've browsed to CN=Services, CN=Microsoft Exchange, CN=<my exchange organization name>, CN=Administrative Groups, CN=First Administrative Groupe, CN=Servers. There is only one server listed: my broken Exchange server, no old 5.5 server ...
No Exchange 5.5 server to remove, so why is the setup program asking for it ...
Renato Montenegro RusticiIT SpecialistCommented:
No idea. Keep searching the knowledge base.
RBraatAuthor Commented:
Nothing usefull I can find.
But when I was looking with ADSIedit, I noticed that my exchange server was appearing with it's old name, of couse. But in the beginning, whan the exchange server was no longer part of the domain, I've added again with another name. So ... maybe this can be part of the problem.
So I've cleaned up my AD (the old name was still appearing as a DC, removed it now) I've changed back my Exchange server to it's original name.
Now rebooting and probably have to wait again for another 3 hours to het the "Applying computer Settings" screen to go away ...
Hopefully, after this, the reinstall works without the annoying dialog ...
RBraatAuthor Commented:
Renamed the Exchange server back to it's original name and reinstalled Exchange. Now the 5.5 screen has dissapeared, was able to reinstall Exchange. After that reapplied SP2.
All exchange services do start.

However, none of the stores are able to mout: "The database files in this store are corrupted". So I ran ESEUTIL with /mh and it was a dirty shutdown (of couse).

I ran exeutil with /p to repair and it tels me the operation completed succesfully. After that, I tried to mount again, but it tells me again "The database files in this store are corrupted", so it did now work.

Any idea?
RBraatAuthor Commented:
I followed this http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_21988086.html so I ran eseutil /d and eseutil/ p on every edb-file in all stores. After that I removed all log files of the storage groupe. Then I was able to mount the datastores per storage groupe. Not quite finished, have a lot of stores in 4 groups, but everytime it seems to be working till now.

Am I missing something or have I taken all steps in the recovery process .... ?


OWA does not work, this might be becase of the denotion, so the anonymous account is wrong? Will be tomorrow when I look for it, kinda late now, done a lot of work ...
Renato Montenegro RusticiIT SpecialistCommented:
I saw you had lots of fun in the mean time. Well, I think you should evaluate all your disaster recovery plan for the next time. You really should have regular backups to avoid this kind of situation.

Take a look at this document to help you with the OWA issue:

How to reset the default virtual directories that are required to provide Outlook Web Access, Exchange ActiveSync, and Outlook Mobile Access services in Exchange Server 2003
http://support.microsoft.com/kb/883380
RBraatAuthor Commented:
The virtual dir's did still exist, but IIS is now using the local ISR account (after denotion) and permissions were set of domain's IUSR account. Changed the accounts and everything is working again.

Thank you for helping and sticking with me in times of fun  :-)

Next step: organize my backup again. Funy story: backups were always fine, every day, no probem. Until I ran out of storage. So I've expanded my NAS in order to have more storage so I could make correct backups again. But it was the expansion of the NAS which corrupted my VM which lead to this all (as i started with above in the problem description).

regards!
RBraatAuthor Commented:
For sticking with me ;-)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.