• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1078
  • Last Modified:

Server 2008 and WDS, how to setup with a HP ProCurve 2724 switch?

I'm really a newbie in the network field and I have recently installed W2K8 R2 Enterprise on a laptop for testing purposes. I want to use it as a WDS-server with wim-images and to distribute drivers. I've configured DHCP with a scope and added a boot image to the WDS-server. I've hooked the server up to a HP ProCurve 2724 switch which has been reset to default with the front button. Problem is that the client which I want to capture an image from but it doesn't get an IP when trying to boot with F12 (the NIC in the client laptop does of course support PXE). DHCP starts on the client, but somehow it doesn't recieve an IP and goes on booting to Windows (7 Pro).

What am I missing here? Does the server have to be connected to the switch with a crossed TP-cable or can I use the "regular" CAT5 I got and do I have to configure the switch somehow?
0
elzacka
Asked:
elzacka
2 Solutions
 
penguinjasCommented:
http://social.technet.microsoft.com/Forums/en-US/winserversetup/thread/e84c8a4c-a6da-4c4a-8ca6-2a1007b205ae/

Configuring When DHCP is on the Same Server
The method of communication between the booting client and the server uses data fields (known as options) in DHCP packets. The Windows Deployment Services solution for booting over the network works well in many configurations. It works well when Windows Deployment Services is located on the same physical computer or on a different physical computer than the DHCP server. However, the default installation is that Windows Deployment Services and a DCHP server (Microsoft or non-Microsoft) are located on different physical computers. In this scenario, no additional configuration steps are required for interoperability between Windows Deployment Services and the DHCP server.

However, if you are running Windows Deployment Services and DHCP on the same computer, in addition to configuring the server to not listen on port 67, you will need to use your DHCP tools to add Option 60 to their DHCP scopes. This allows booting clients to learn about the Windows Deployment Services PXE server from the DHCP response that is generated by the DHCP server. Setting DHCP option tag 60 has one side effect: clients booting from the network are always notified that the Windows Deployment Services PXE server is available, even if the server is not operational or has stopped. For instructions on configuring these options, see the DHCP section of How to Manage Your Server.

Note
There are some scenarios (particularly those that require running a DHCP server) that do not support adding custom DHCP option 60 on the same physical computer as the Windows Deployment Services server. In these circumstances, it is possible to configure the server to bind to UDP Port 67 in non-exclusive mode by passing the SO_REUSEADDR option. For more information, see Using SO_REUSEADDR and SO_EXCLUSIVEADDRUSE (http://go.microsoft.com/fwlink/?LinkId=82387).

If DHCP is installed on a server that is located in a different subnet, then you will need to do one of the following configure your IP Helper tables (recommended) or add DHCP options 66 and 67. For more information, see Managing Network Boot Programs.

 

And here are some procedures:

 

To configure Windows Deployment Services to run on the same computer as Microsoft DHCP

        
Right-click the server and click Properties.

On the DHCP tab, select Do not listen on port 67 and Configure DHCP Option #60 Tag to PXEClient.

 

This procedure does the following:

Sets HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Parameters\UseDhcpPorts to 0.

Adds the option 60 PXEClient tag to all of your DHCP scopes.

To configure Windows Deployment Services to run on the same computer as non-Microsoft DHCP

Right-click the server and click Properties.

On the DHCP tab, select the Do not listen on port 67.

Use your DHCP server tools to set Option #60 Tag to PXEClient.
 

This procedure sets HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Parameters\UseDhcpPorts to 0.
0
 
jburgaardCommented:
All ports are Auto MDI/MDI-X , so the switch will automaticaly find needed type of connection, so you do not have to care about using regular or crossed type of cable.
I would use min. Cat5e cable for giga-connection (not Cat5).
0
 
elzackaAuthor Commented:
Thanks, both of you. I'm quite sure I've added the option 60 to the scope and configured the server not to listen to port 67 but I will double check tomorrow and get back to you.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
penguinjasCommented:
Oh, a lot of BIOS setups do not have PXE turned on.  I know on the Dell BIOS versions I've seen there is an option for PXE/ON you have to set for it to become available in the F12 menu.

Also, at what point is it failing?  When you hit F12 and select to PXE boot the mac comes on the screen and then you should get some messages like connecting to 10.1.1.20 and some fail message at the end, like failed to boot retry.  Are you getting these messages?
0
 
elzackaAuthor Commented:
It's a Fujitsu Siemens S7110-laptop and the network boot is turned on in BIOS. It displays the MAC address and further it tries to connect with the DHCP-server without any luck. It never connects.
0
 
Martin81Commented:
Check that the WDS service is running.
0
 
elzackaAuthor Commented:
Thank you guys. Honestly, I don't know exactly what solved it, but re-creating the DHCP-scope and re-configuring the WDS did it. With all the hints you gave me It now finally recieves an IP from the DHCP-server and boots to the WDS-menu. The switch doesn't need to be configured as it is an "unmanaged" switch. Neither do I have to use a specific kind of TP-cable as long as it is CAT5.

The problem now is that I recieve an error when I'm trying to capture an image from the Fujitsu Siemens laptop:

Windows Boot Manager (Server IP: 192.168.001.080) <--- Why this address? The server IP is 192.168.1.80...
Windows Failed to start...
File: \Boot\BCD
Status: 0xc000000f


This is another problem so I guess I have to create a new post for this?
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now