VLC Will Not Launch On Ubuntu 10.4 / Back | Track5

Posted on 2011-10-02
Last Modified: 2012-05-12
Okay this one is throwing me for a loop. I have installed VLC media player on Ubuntu 10.4 / Back | Track5 but it will not launch. I have uninstalled and reinstalled it, tried running it from the terminal and the quick launch icon, as well as by associating a file with it and double-clicking the file. Nothing has worked thus far. I use this machine to learn Back | Track and have many .flv files that I need to view. The only troubleshooting info I found is the following but it applies to Mac:

VLC does not launch on my Mac anymore. What to do?

    Please have a look at the specific FAQ, which covers multiple solutions to this issue.

Error Messages

Error messages can be viewed by selecting Messages from the Tools menu.
main private error: no sout mux module matched "ts"

    This can be an error if libdvbpsi was not installed when vlc was compiled. To fix this error, install libdvbpsi; then re-compile vlc. libdvbpsi

Any help would be greatly appreciated!
Question by:BoxunloX
    LVL 37

    Expert Comment

    by:Gerwin Jansen
    Hello BoxunloX, you say you tried starting vlc from a terminal. When you start it that way, it is sending (debug) output to the terminal window. You must be getting some error message, what is it? How did you install it btw, through a package manager or otherwise?
    LVL 87

    Accepted Solution

    The problem is that backtrack is run as root, and VLC won't run as root. Create another user, logon as that user and then run VLC.

    If you want to learn backtrack it is probably better and easier to install as a Virtual Machine within VMware Player (free), or Oracle's Virtualbox (also free). You can then run BT simultaneously with your normal OS, run all those multimedia things in that OS, and then test your things in the VM.

    Backtrack even used to offer VM's for download so you wouldn't have to run the installation, but I'm not sure whether that is still so.
    LVL 1

    Author Closing Comment

    That was it exactly. VLC won't run as root.
    LVL 1

    Author Comment

    Thanks to gerwinjansen as well for the quick response!

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
    Keep your audience engaged and get the most out of your next presentation with these quick Prezi tips.
    This video will give a brief orientation and organization of Logic Pro X, and how to access different work spaces quickly with keyboard shortcuts.
    Viewers will learn the basics of using Ableton Live's advanced sampler instrument, Sampler. Load new Sampler into an empty MIDI track: Select a sample and drop it into sample window in Sampler: Adjust pitch if necessary with Root Key setting: …

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    8 Experts available now in Live!

    Get 1:1 Help Now