• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1645
  • Last Modified:

Export Crystal Report 2008 to csv has extra blank lines

When I export a Crystal Report 2008 to csv I randomly get extra blank lines.  How can I eliminate this from happening?
0
cookedwb
Asked:
cookedwb
1 Solution
 
mlmccCommented:
Do you have a subreport?

Do you have blank lines in the report?

mlmcc
0
 
JHolycloudCommented:
If you say "Randomly", is it possible that your dataset has blank/NULL value ? So CR will show blank lines regarding this NULL value on your dataset records.
0
 
cookedwbAuthor Commented:
Yes to the subreport, but its not always showing blank lines after or before a row that had the subreport values displayed. The blank lines only appear when the report is exported as a csv.   I've set the subreport to suppress if blank.  No blank lines in the report.  I originally created the report with CR10 and when exporting to CSV it would put the headers on each row. So I saved it in CR2008.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
HlanaiCommented:
From Crystal XI u will have issue with export to excel and csv. On the opt of the report design, where you have the number line, you need to click and put he column markers, which determine where each colum will start and end, fit your fields in between each column marker and your export will be fine.

as for your rows, you have to make sure that the fields have the same height and they are top and bottom aligned. So, fields in the same column must be left and right aligned and fields in the same row must me top and bottom aligned.

Let me know if you have a problem doing this.
0
 
mlmccCommented:
Are any of the fields more than 1 row high when they grow?

Are any lines longer than others?

mlmcc
0
 
cookedwbAuthor Commented:
I've set all the detail fields to the same size and aligned them to top.  Closed the detail section to fit, and removed my subreports.  The CSV is pipe separated.  The blank lines show the empty cells with pipes between them but they are random.  When I run the report in crystal I don't have any extra spaces between the patient information.  I'm still stumped.  I continue to play with the formatting to see what occurs.  Any more suggestions is greatly appreciated.
0
 
mlmccCommented:
Do you have any conditional suppression on the detail section?

mlmcc
0
 
cookedwbAuthor Commented:
That appears to be the problem.  Is there a way or setting I need to set to keep the conditional suppression and still export without the spaces?  I'm running my report against a kb-sql database. The field i have the conditional suppression against is not an primary key within that table and the report takes a very long time to run if I add that statement within the record selection.
0
 
cookedwbAuthor Commented:
Thank you mlmcc for helping resolve this problem.  I was able to readjust my selection statement against the kb-sql database and the report run within a normal amount of time and pulls the data as expected.  The conditional suppression was removed and the file exported in a csv format with no extra lines.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now