• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 654
  • Last Modified:

Remote Web Workplace keeps shutting down after about a day of server runtime

Every time I reboot this SBS2003 server the RWW works for about a day then just stops for no reason.
People can access http://myipaddress/remote
Then log in as normal but instead of getting the RWW page they get a page split in 2 with a message in the toip half saying the page cannot be displayed and a messager in the bottom half saying loading. It just stays there. Restartng IIS services dont make any difference. Windows updatres dont help and there have been no configuration changes on this server in over 12 months.

The only error i can find is this in the event log

The following fatal error occurred in the Remote Web Workplace application:
      URL:            https://myipaddress/Remote/header.aspx
      Error Message:      An operations error occurred
      Stack Trace:         at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   at System.DirectoryServices.DirectoryEntry.Bind()
   at System.DirectoryServices.DirectoryEntry.get_AdsObject()
   at System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne)
   at System.DirectoryServices.DirectorySearcher.FindOne()
   at remote.RAPLinks.getCurrentUser()
   at remote.RAPLinks..ctor(HttpRequest httpRequest, HttpServerUtility httpServer, HttpSessionState httpSession)
   at remote.Global.getRAPLinks(HttpServerUtility httpServer, HttpSessionState httpSession, HttpRequest httpRequest)
   at remote.header.Page_Load(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain()

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

And thats it, no matter what services i restart i cant get the RWW back. Only a reboot will fix this. Then its the same thing all over again within a day or so.
0
craigueh
Asked:
craigueh
  • 4
1 Solution
 
stergiumCommented:
hello.
Please check this answer to a similar problem.
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_23301067.html
and please feed back.
0
 
craiguehAuthor Commented:
Thanks, ive already read through that thread but the solution was not found. This is definitely not a DNS issue because if i try the RWW page directly on the server itself using the servers own internal IP it stillproduces the same result. Even though it used to work fine using the internal IP in the past. So that rules DNS out of the equation.
0
 
craiguehAuthor Commented:
Has anyone else any input on this issue?
I am my witts end at this stage.

Thanks
0
 
craiguehAuthor Commented:
For anyone else having this issue i found the cause.

It has to do with a new RID pool not being assinged to the servers active directory.
This is due to an old domain controller that was demoted and reoved from the active directory but hadnt been removed fully. The primary doain controller was trying to replicate AD to the removed server and couldnt. The RID pool ran out and new one wasnt issued because the AD had inconsistent data. I ran Metadata Cleanup to tidy up the remnants of the failed demotion and all is well since.
0
 
craiguehAuthor Commented:
i'm closing this question myself.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now