Citrix Xenapp 6 locks up on server 2008 R2 Sp1

Our Citrix server locks up on a fairly regular basis, when it does it kicks everyone out and the only way to get back in is to perform a hard boot of the sever.   What is happening is the server is stopping ICA, RDP, and local access to it.  It is not going fully down.  It is still responding to pings while it is in this state.  I have contacted Citrix on this and they have been very slow in getting back to us.  Does anyone have any suggestions?  I have installed all of the Citrix Hotfixes for this box and the recommended MS ones as well.
cberingerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony JohncockLead Technical ArchitectCommented:
Is there any perceivable pattern to it? Can you track it to when a particular user is doing something, say?

Aything in the event logs?

It might be worthwhile monitoring with performance monitor to see if anything ramps up just prior to it happening.

It's been a long time since printer drivers were really able to cause this kind of behaviour, but it might be worth checking through which you have installed on the server and update them to the latest available.

Any AV software that might be causing problems?

How is the network in general when it happens?

The servers aren't virtual are they? I've seen this behaviour when storage connectivity is lost.
simplejackCommented:
The only thing I can tell to you - you are not alone :)

We can't contact Citrix, since we are only testing xenapp now and preparing it for production. Installing Xenapp 6.5 don't solve this prolem, it still occurs every 7-10 days.
Tony JohncockLead Technical ArchitectCommented:
Simplejack if you go through a partner, they should be able to raise a call on your behalf.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

cberingerAuthor Commented:
The only event that shows is Event Id 1000
Faulting application name: svchost.exe_TermService, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1
Faulting module name: rpm.dll, version: 6.0.26.10226, time stamp: 0x4ce2f24c
Exception code: 0xc0000005
Fault offset: 0x000000000007ba22
Faulting process id: 0x16a8
Faulting application start time: 0x01cc7e9d76b410d8
Faulting application path: C:\Windows\System32\svchost.exe
Faulting module path: C:\Program Files (x86)\Citrix\System32\rpm.dll
Report Id: e9cea73e-ecb3-11e0-81f8-782bcb283256

No pattern to it at all.  No printers installed on the server. Disabled the AV to see if that was the issue, no help.  Physical servers not virtual.  The network is great even when this happens it only causes problems with the citrix server only.
Tony JohncockLead Technical ArchitectCommented:
Ah have you seen this thread:

http://forums.citrix.com/thread.jspa?threadID=273399&start=0&tstart=0

Leads to the following hotfix (you need a MyCitrix login as it's a private hotfix)

http://support.citrix.com/article/CTX128043

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cberingerAuthor Commented:
I have not tried that hotfix yet but will try it tonight afterhours since it requires a reboot.  Thank you very much for the suggestion.
Tony JohncockLead Technical ArchitectCommented:
You're welcome.

Do you have access to mycitrix to get it? If jot, as I'm a partner, if you use the hire me button in my profile I can get it for you.
cberingerAuthor Commented:
I do have access, thank you very much thou!
cberingerAuthor Commented:
I applied the hotfix late last night and will update this case as to if it has resolved the issue.
cberingerAuthor Commented:
So it has been about a week now with no lock up.  Looks like that hotfix fixed it.  Amazing the Citrix Tech support didn't recommend it to us.  Thanks Again!!
Tony JohncockLead Technical ArchitectCommented:
My experience (as a partner) is it quite simply depends who you get to speak to. Some are somewhat better informed than others.

Glad I could help in some small way :-) Thank you for the points.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.