Open ports RRAS without NAT function

Hi everyone,

I have a problem with the RWW on my SBS 2003. RRAS is active for the VPN-connections which is its only purpose. NAT is not configured because it only has 1 NIC.
When a client of mine wants to use RWW to take over his desktop at work, he receives the following message you can see in the image. Yesterday when I tried, I got another message: "Connectivity to the remote computer could not be established"
rww error
Port 4125 is forwarded on the router, but I think that the port is not open on the server. I can't access the windows firewall anymore, because IPNAT.sys in running.
I executed the command: netstat -aon | find ":4125" but nothing returned, so I guess that the port is just not open at the server.

I also can't change anything in the RRAS to open these ports. I have read something about NAT/Firewall in IP routing under RRAS, but this is not visible. I think this is because RRAS just provides VPN-access to the users and no NAT.

Any idea how I can fix this problem or open ports under RRAS? I tried to disable RRAS, but lost connection to my server, so used vsphere to enable it back again. RRAS needs to be enabled, because when I tried to access the terminal server, it gave me the message that it can"t find the specified domain when I tried to login.

Thanks!!
Silencer001Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

marcustechCommented:
First thing i'd do would be re-run the "connect to the internet" wizard in SBS - either do Start --> Run --> "ICW" or run it from the SBS Management interface. This should configure the remote access and NAT settings correctly.
Silencer001Author Commented:
Thanks for the suggestion marcustech. I ran the wizard "Connect to the internet" but still no change.. The port isn't opened.

Do you have some other suggestions that I could try?
Silencer001Author Commented:
It still seems that there isn't listening something on port 4125, succesfully completed the wizard + done an iisreset.
Cloud as a Security Delivery Platform for MSSPs

Every Managed Security Service Provider (MSSP) needs a platform to deliver effective and efficient security-as-a-service to their customers. Scale, elasticity and profitability are a few of the many features that a Cloud platform offers. View our on-demand webinar to learn more!

marcustechCommented:
Can you remote desktop to client PCs internally? What about if you browse to the Remote Web Workplace by running internet explorer on the server (log onto server and browse to https://localhost/remote )? Regarding port 4125, this will only be opened "on demand" by SBS when the connect to computer script runs, until then it won't be listening on this port - as long as nothing else has used the port in question, which is what the netstat -aon | find ":4125" is checking for.
Silencer001Author Commented:
Ah ok thanks for the clarification! I just tried it marcustech and locally it's no problem. Just connecting from the outside isn't possible..
Silencer001Author Commented:
OMG, I just checked the router.. My collegue had just added the policy to enable port 4125 over the network (trust to untrust and the other way around). She didn't make a NAT-rule to map the IP-address..

My mistake! Thanks for your suggestions, I have learned from it! Will award point for your trouble! Thanks mate!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Silencer001Author Commented:
I just checked the firewall myself and this was the cause.. Port was not forwarded to the SBS-machine.
marcustechCommented:
Glad you got it sorted fella.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.