[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Tag Interal EIGRP Routes

Posted on 2011-10-03
2
Medium Priority
?
399 Views
Last Modified: 2012-05-12
Hi there. I am trying to tag routes learned from an internal EIGRP neigbour. I have router B that has two loopback adapters advertising networks 1.1.1.0 and 1.1.2.0/24 via EIGRP. Router A learns the routes on its Fast 0/1 interface. here is the abasic configuration I have;

access-list 1 permit 1.1.1.0 0.0.0.255
access-list 1 permit 1.1.2.0 0.0.0.255

route-map PBR permit 10
match ip add 1
set tag 40

router eigrp 10
distribution-list route-map PBR in fast 0/1

When applied it forces a resync of the neigbour relationship but does not tag the routes. What am I doing wrong?
0
Comment
Question by:Leedham2answers
  • 2
2 Comments
 
LVL 6

Accepted Solution

by:
Sanjeevloke earned 2000 total points
ID: 36908664
route-map EIGRP_TAG permit 10
 match interface Loopback0
 set tag 4755


router eigrp 10
 redistribute connected route-map EIGRP_TAG
 network 172.16.10.0 0.0.0.255


Router#sh ip route 100.100.100.1
Routing entry for 100.100.100.0/24
  Known via "eigrp 10", distance 170, metric 2297856
  Tag 4755, type external
  Redistributing via eigrp 10
  Last update from 172.16.10.1 on Serial0, 00:00:22 ago
  Routing Descriptor Blocks:
  * 172.16.10.1, from 172.16.10.1, 00:00:22 ago, via Serial0
      Route metric is 2297856, traffic share count is 1
      Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1


i can c 4755..


u used ...
access-list 1 permit 1.1.1.0 0.0.0.255
access-list 1 permit 1.1.2.0 0.0.0.255

now distribute-list is basically used for route filtering ...
so i think the IP which ur using for neighborship are denied at end of ACL ..
try to permit neighbor IP in ACL and check ..
0
 
LVL 6

Expert Comment

by:Sanjeevloke
ID: 36908880
try to permit neighbor IP in ACL and check ..
or
route-map PBR permit 20

a blank route-map is required to permit other traffic
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question