Cannot print from Windows 7 - possible spool issue

I am using a Windows 7 Professional on my laptop connected to my company's network. For the month since buying the new laptop I have been printing without any problems but suddenly I cannot print ANYTHING neither here at the office nor via Wifi on my home printer.
 
At the office I had configured my printers as "local" through "standard TCP/IP port" and defined the IP addresses of the printers. This setup has been working 100% flawlessly. Now nothing. I have tried:

Looked at Services to make sure the Print Spooler service is running which it is but just for good measure stopped and re-started.
Uninstalled and re-installed the printers changing the default printers to no effect.
Followed some advice from forums and switched off SNMP -nothing
I have gone into "Programs and Features" and switched on LPD Print Service as someone else suggested.
Downloaded the MS troubleshooting tool to no avail
Pinged the printers and they all respond OK
Using the printers' IP address I have logged into the printers Config application and reset the printer successfully
Disabled iPv6 but made no difference

Everyone else in the office is printing fine on the very same printers.
I am DESPERATE as I cannot print ANYTHING, ANYWHERE!
Please please help if you think I have left something out.

Regards and thanx in advance
Alexis
 
Alexis_CYAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

maeltarCommented:
You uninstalled and re-installed the printers, did you just delete them or did you uninstall the software, as it sounds like your driver is corrupt..
pdantroCommented:
Download the driver from the printer website and go to the printer properties advanced tab and make sure it is using the current driver you just downloaded.
penguinjasCommented:
Try clearing your arp cache.

netsh interface ip delete arpcache
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Run5kCommented:
Try clearing out the print spooler on that local machine:

1. Open a command prompt with full admin privileges:  click on the Start orb, enter cmd in the Search field, right-click on the command prompt icon and select Run as administrator

2. Within the command prompt enter net stop spooler

3. Use Windows Explorer to navigate to %systemdrive%\Windows\System32\spool\printers\ and delete all of the files within that folder

4. Return to your elevated command prompt and enter net start spooler
Alexis_CYAuthor Commented:
Hi - thanx for responding.
The problem exists with ALL printers that I have previously used here at the office, a colour Brother a Kyocera an also my trustred color Oki at home so I think it is highly unlikely to be a printer driver issue. Regardless I removed two of the printers that I had previously installed and re-installed them with both the Microsoft supplied drivers and the manufacturers. In all cases the print job just sits in the queue and all I get is an exclamation mark (!) on the printer icon suggesting I use the "troubleshoot" which of course I do and it does not yield any "solutions"
pdantroCommented:
Use the printer wizard and try doing add a network printer, then the printer that i want wasn't listed, and select the option to add using tcp/ip or host name and see if it works correctly though that setup and hopefully windows will detect and install whats needed for it.
blakogreCommented:
I'd like you to check your System and Application logs for errors related to printing.  Post them here.

Do the jobs go to the queue and disappear, and nothing is printed?

Make sure you/everyone has write permission to the spool folder.
Alexis_CYAuthor Commented:
Hi all,

OK, I have cleared all spooled files as suggested but alas no difference.

I install the printer using the following steps:
a) Add printer
b) Add Local printer
c) Use an existing port
d) Choose "126.0.0.31(Standard TCP/IP Port) which I had previously PINGed to make sure I can talk to.
e) Choose make and model (Kyocera FS-3920DN) or (Kyocera FS-3920DN (KPDL) for the Kyocera supplied driver..
f) Replace the current driver to make sure fresh install
g) Print test page
h) Print queue shows "printing" for a bit and then "Error-Printing" with no details
i) The folder C:\Windows\System32\spool\PRINTERS shows 2 files; an .SHD and .SPL

pdantroCommented:
Check the event log for print error and see if you can find the error and copy and paste it here.
Alexis_CYAuthor Commented:
Just looked at the Application and System Windows logs and there are no warnings or errors around the time of the print request - I can print another job now and paste to show you
Alexis_CYAuthor Commented:
No events generated for the failed print job neither in Application nor System
penguinjasCommented:
You can try going for the complete clean of the printers from your workstation.  This process will delete all printers on your system and print drivers and clear out the registry keys.  Once complete try adding the printer again.  

Here's how to clean up the print spooler stuff manually.
 
Warning! be very careful using regedit - if you delete the wrong things, you may render your computer inoperative!

open regedit (e.g. click Start, key regedit and press Enter)

navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers

under this key, there will be the keys Version-2 and Version-3 (one or the other of these may be absent - not a problem)

the sub-keys under these contain the printer driver configuration information

delete all the sub-keys inside Version-2 and Version-3, but not these keys themselves

The Microsoft Knowledgebase article at http://support.microsoft.com/default.aspx?scid=kb;en-us;312052 lists some other registry entries to delete, but this is not usually necessary.

open a Command Prompt window

key the commands
       net stop spooler
       net start spooler

open Windows Explorer

navigate to %systemroot%\system32\spool\printers\ and delete any files there.  By default, this is where the print spooler stores print files.

navigate to %systemroot%\system32\spool\drivers\w32x86 (%systemroot% is usually Windows, but it might be winnt or something else; this is set when the OS is installed).

inside w32x86, there will be folders with the names 2 and 3 (one or more of these may be absent - not a problem)
       delete all of the files and sub-folders in each of the 2 and 3 folders, but not the folders themselves
     inside w32x86, there may be other folders with names starting with "hewlett_packard", "hphp" or something else; delete these folders also

restart the print spooler
Alexis_CYAuthor Commented:
Hi there

Thanks for the response.
My printing problems extend to printing through WiFi at home with the same behaviour - do you still think it is worth going through the registry approach. The Stop/start spooler did not cure anything.

Also, and I am not sure if this is relevant, I recently installed MODI (Microsoft Office Document Imaging) (part of Microsoft Office tools) for the purposes of using it for some OCR requirements that I have. Could this be causing these problems that I am experiencing?

Alexis
edpowell19Commented:
I have a user experiencing a similar issue and it was fine yesterday. Any program she attempts to print from stops responding. She's using a Dell Optiplex 990, 64bit Windows 7, 8GB RAM with networked HP printers. She is the only one experiencing the issue...I will check to see if any Windows updates installed last night...
edpowell19Commented:
Additional info: That's Win7 Pro 64 w/SP1, the last updates were installed on 9/28 so it doesn't look like that's the issue. I can successfully print a test page to any of the printers. We are not running MODI.
penguinjasCommented:
Alexis, have you tried directly attaching a printer through USB to test printing.  It would be nice to completely eliminate the possibility it is network related.
Alexis_CYAuthor Commented:
Hi Penguinjas,

Just tried your USB suggestion.
Disconnected, the printer from the network, plugged in my USB cable connected the laptop, drivers loaded automatically and fired a test page - working great!

Whatever the problem is it's network-related (Ethernet and WiFi)!

Thanx
Alexis
Alexis_CYAuthor Commented:
SOLVED

I noticed some unusual behaviour with my virus protection software (Panda Global Protection 2012) and called their support here in Cyprus. I also mentioned printing problems as well as they said that they were aware of some problems caused by a recent update.
Removed Panda 2011, replaced it with 2012 and voila - printing is fine and so is virus protection.

Good result!

Thanx to EVERYONE for their suggestions and help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Alexis_CYAuthor Commented:
I resolved the issue that I raised myself in the end.
It was related to a bug in my Virus Protection software (Panda 2011)

Upgraded to Panda Global Protection 2012 and the problem has been resolved.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.