• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 229
  • Last Modified:

Microsoft Exchange DNS Question

I have a Microsoft exchange 6.5 installed on a box with Small Business Server 2003.

All PCs and notebooks on the local network or connected using a VPN can access the Exchange Server via a generic.generic.local address.

Mobile devices such as smart phones and tablets are currently configured to access via the WAN address (generic.generic.com), but cannot access the Exchange Server when they are on the local network.

Should I not be able to do some type of DNS forwarding in my local network settings which would intercept these devices when they send out a query for the generic.generic.com address and instead forward them to the generic.generic.local address?

This is the same box of course, but I am stumped.
0
mnbookman
Asked:
mnbookman
5 Solutions
 
achaldaveCommented:
you need to create A record for generic.generic.com with internal ip address on your internal DNS server.
0
 
dswattCommented:
Sounds like your using Exchange 2003. Are your smart devices connecting to OWA?
Try http://www.msexchange.org/tutorials/configuring-exchange2003-http-remote-access.html that should help redirect them to local.
0
 
mnbookmanAuthor Commented:
achaldave, would this be under forward or reverse lookup zones? If you could tell me what area under the creek don't put it in as well, I would be very appreciative.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
achaldaveCommented:
it should be under the forward lookup zone. go to zone generic.com and create A record OWA. so if your OWA is abc.xyz.com then you should create record for abc under xyz.com forward lookup zone.
0
 
mnbookmanAuthor Commented:
achaldave, sorry that I am so dense.

The.com domain is hosted elsewhere, but the exchange server is hosted locally. Since the exchange is generic.generic.local, I do not have a.com domain area set up.

Thus, when I add an a record in the forward lookup zone, it looks like generic.generic.com.LOCALGENERIC.local.

How do I get around the DNS record depending a local suffix to the FQDN?
0
 
achaldaveCommented:
Anything else the .com domain is used for other than exchange?

Creating new zone for generic.com is one of the options, you might need to copy other recrods from your currently hosted dns server.

Are you able to resolve generic.generic.com form you local network? if you can then the issue I think is related to network, you might want to work with network guy so he can redirect any request going to external ip of generic.generic.com to internal address.
0
 
mnbookmanAuthor Commented:
The .com, on a linux box outside the LAN, is used to host a website.
0
 
achaldaveCommented:
ok you can create new forward lookup zone for .com on internal server, create A record for OWA with internal IP and create other records i.e. for websites with external ip addresses.
0
 
jaredr80Commented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now