Adobe view in browser

Windows XP SP3 plus Adobe Acrobat Pro 9.
Getting an error:
Cannot use adobe reader to view pdf in your web browser

Open in new window

However there is no Adobe Raeder in my machine. I checked the registry, the image is attached.

Thanks Adobe
zhshqzycAsked:
Who is Participating?
 
captainCommented:
Have you got the latest version of Acrobat 9 installed?

Update to 9.4.6 and then we take it from there:
http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows
0
 
knwarrior74Commented:
This problem can occur for the following reasons:

•Acrobat or Reader can't read the PDF file.
•The web browser isn't configured correctly with the Adobe PDF Browser plug-in.
•The web server on which the PDF file is stored can't serve the PDF file.
•You are using a 64-bit version of the Internet Explorer browser.

One of the following changes should help you. Try these and let me know how it goes.

1. Open Acrobat
2. Go to Edit > Preferences > Internet
3. Uncheck "Allow fast web view"

1. Open Acrobat 8.1.7
2. Go to Edit > Preferences > Internet
3. Uncheck "Display PDF in Browser"

disabling the Adboe Splash Screen under Edit / Preferences / General / Application Startup

disabled the "Getting Started with Adobe Acrobat 8 Professional" screen that comes up when you open Adobe, by selecting the "do not show at startup" option on that window.


1. Create a .reg file using Notepad
2. Copy the following in document (all in between the hashmarks) or use registry doc i attached to this response

--------------------

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\DefaultIcon]
@="C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe"
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell\open]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell\open\command]
@="C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe /u \"%1\""
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SOFTWARE\Adobe\Acrobat\Exe]
@="\"C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe\""

-----------------------

3. Save as something like AdobeFix.reg
4. Run regedit and import this entry into your registry then restart PC.
0
 
captainCommented:
@knwarrior

If you paste something from another website such as Adobe it is best practice to site the reference at least or better link to the page. Just pasting it leads to issues like above not being applicable or referencing the wrong software, which if you give advice to indiscriminately import registry values is not ideal.

That said, some of the advice may work to resolving this.

I would first check under a different reg key whether Reader is not present:
HKEY_CURRENT_USER\Software\Adobe

If there is no Reader entry under above you should be clear. If there is start Reader by locating AcroRd32.exe (usually in the Program Files folder as in previous post). Once started disable the display in browser option in preferences.  

Then start Acrobat Pro and enable the same option.

hth
capt.
0
 
zhshqzycAuthor Commented:
I tried everything but it is not working. There is no Adobe Reader entry in my machine.
0
 
zhshqzycAuthor Commented:
Maybe reinstall it is the only choice.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.